1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I cannot start Wireless Zero Configuration service, or select right network??

Discussion in 'Hardware' started by On edge, Jul 15, 2008.

  1. On edge

    On edge Corporal

    I use DSL at home, but something went wrong and now my computer cannot connect to it through the wireless adapter. A cable connection still works, which is what I'm currently using, and the wireless adapter itself must be fine since it does connect to random networks.

    I try to select my own secure Verizon network, but I cannot view the list of available networks (Windows cannot configure them), and I cannot start Zero Configuration utility either. The exact messages I get when I try are shown in the linked pics. I've tried the usual things, but without success.

    Pics here (earlier thread): http://forums.majorgeeks.com/showpost.php?p=1178993&postcount=10

    When I try to start WZC manually from 'Control Panel -> Administrative Tools -> Services' I get "Error 1068: The dependency service or group failed to start." From WCZ's properties, the path is: "C:\WINDOWS\System32\svchost.exe -k netsvcs" and the dependencies are "NDIS Usermode I/O Protocol" and "Remote Procedure Call (RPC)." The former I do not see listed in the 'Services' list. The latter has been 'Started,' and for good measure I made sure all other 'Remote' services were started, except for Remote Registry, which failed to start (error 1079).

    Any ideas?
  2. lbmest

    lbmest MajorGeek

    Sounds like you have a second wireless connection service (ex. IntelPro) configuring your connection. Check your installed programs for this. That might be causing the conflict with the WZC service.
    Can you log into the router configuration page by cable connection and see if the SSID broadcast is disabled? If so, enable it for a short time to try to reconnect. Sometimes a quirk can kick up which will knock out your connection. (If you ran some of the malware fixes, this is a distinct possibility.)
    Here is a good guide for checking out your wireless connection.
  3. On edge

    On edge Corporal

    How can I check if a particular program is reponsible. Suspects include:

    Agere Systems HDA Modem [No idea what this is or when it was installed, but it may have been there since the beginning...]

    Apple Software Update [I'm using a HP Compaq 6710b laptop, so no idea how the Apple thing got there - it may have been some compatibility pack...]

    Broadcom NetXtreme Ethernet Controller [This is probably something to involving my Broadcom NetLink(TM) Gigabit Ethernet adaper, but who knows...]

    Hi-Speed Bridge-Network USB cable [could this be responsible? I think it came with a USB-to-USB data transfer cable for connecting two computers...]

    HP Broadband Wireless Modules [??]

    HP Wireless Assistant [I think this program has been there for a long time, but perhaps it has changed...]

    and there may be others that I missed...


    Is page shown in the attached pic the router config page? If so, SSID looks enabled.

    Thanks for the link. Still going through it. Just wanted to know check if there's a second service configuring my connection?

    Attached Files:

  4. lbmest

    lbmest MajorGeek

    I think the Wireless Assistant is the program that may be the one. You should have an icon in the lower right of your taskbar for it.
    Here is a link to an update download for it. (In the description is a fix for the icon not showing up in the taskbar, so it may be running with no icon.)
    Also, if you ran the malware guide, you should have CCleaner installed. You can use the Startup listing to see if the Assistant is running on start up - Choose Tools > Start up button.
    You have a choice as to using either wireless program, HP or Windows, but only 1 can be running.
    Yes, your SSID is broadcasting from that screenshot which is the correct page.
    The link from the my previous post should guide you pretty well in getting your situation straightened out. Any other problems, just post them.
    Hope this helps.
  5. cat5e

    cat5e MajorGeek

  6. On edge

    On edge Corporal

    I still haven't been able to get the wireless to work. Specifically, I cannot view available networks, and I cannot start WZC.

    I downloaded the update, so that now I have both "HP Wireless Assistant," and "HP Wireless Assistant 1.01B2" installed. I downloaded and installed all available Microsoft and HP updates for good measure, incl. SP3 which I had been avoiding previously. The only one I cannot seem to install is SP34100 (see attachments) - I have the file on my hard drive, but when I restart the laptop after installing the update, it freezes at the 'Windows is shutting down...' screen (or some such) and I have to turn it off manually. Also, HP notes a problem with some serial hardware thing (see pic).

    In any case, my laptop has a light/button above the main keyboard for turning the wireless connection or adapter on/off. ON = blue, OFF = no light. If I disable the HP Wireless Assistant, the light (and adapter) turns off, so then I have no way to get a wireless connection. And if I try to start the WZC service anyway, it still fails.

    I haven't tried uninstalling HP Wireless Assistant because it has been there since I bought this computer, and until recently I was able to connect to DSL through the wireless connection fine, and had no trouble seeing/selecting networks. FWIW, the HP Wireless Assistant symbol is currently (as I type) not present in the system tray.

    See attached pic for startup programs per ccleaner. HP Wireless Assistant is listed, but without the checkmark in front of it.

    I'm still going over everything. I've had to shutdown/restart my computer several times as I've installed various updates. Is there a way to find out what's causing the freeze-ups during shutdown? (I left the computer on for all last night at that screen to make sure it wasn't just a really slow shutdown).

    Also, I currently have the cable connected (to my Verizon DSL), and the wireless connection open (though it only connects to WirelessPhiladelphia at low strength and I cannot choose another network).

    Please let me know if I should disconnect one or the other during these attempts to fix the wireless connection (although I've tried it without the cable, etc.) I also have my original Windows XP DVDs and Verizon DSL CD handy, in case they are needed. If you think of anything, please let me know and thanks for the help so far.

    Attached Files:

  7. On edge

    On edge Corporal

    Attached Files:

  8. lbmest

    lbmest MajorGeek

    Here again, you have to decide which application you want to use, Windows or HPs.

    Did you try the WZC revival procedure that cat5e posted? (To use Windows)

    Put a checkmark in front of the wireless assistant to see if that changes anything? (To use HP)

    You can use Event Viewer. Start > Control Panel > Administrative Tools > Event Viewer Look under Application and System for errors.

    When you say you are connected by wireless, can you actually get out on the internet through that connection?

    In your process listing, you show AVG resident shield and Spyware Terminator shield. I'm not familiar with Spyware Terminator but rule of thumb is to have only 1 resident application running at a time.
  9. Doy22

    Doy22 Private E-2

    If you find that you can not connect to a wireless base station (such as Apple's Airport) because of issues with the XP driver of your wireless adapter (there have been issues with Netgear's MA101 USB adapter for example) then you may find it worthwhile to turn of XP's in-built Wireless Zero Configuration, then install the Windows 2000 drivers and any utilities that your adapter uses.

    This process turns off XP's native wireless support, you will then need to use your wireless adapter's configuration software to configure your wireless network settings.
  10. Unbanable

    Unbanable Specialist

    I glanced through and did not see it mentioned... Have you tried telling Windows to configure the wireless connection? I'm assuming that you still want Windows to, and here is how..

    Open Network Connections. Right click on the wireless connection, and click Properties. Under the Wireless Networks tab, put a check in the box next to Use Windows to configure my wireless network settings. This should allow you to use Windows to view and connect to wireless networks.

    Now then.. What exactly are you currently using - that is, what program - to connect to wireless networks? Where do you go to see that you are connected to what you're connected to?
  11. On edge

    On edge Corporal

    Update: I finally got the wireless connection working again.

    I'm not sure what it was. In the end I just uninstalled HP Wireless Assistant and tried uninstalling HP Wireless Assistant 1.01 B2, but I got the error message shown in the second attachment. I may have uninstalled the wireless modules software too, or anything wireless related.

    Then I downloaded and installed all the HP Service Packs that seemed like they could be relevant to the wireless connection (first attachment). The following programs were added at least (go by memory of what looks new in the add/remove list of programs):

    Broadcom 802.11 Wireless LAN Adapter
    Broadcom Wireless Utility
    HP Broadband Wireless Modules (added or modified)
    HP Connection Manager (added or modified)
    HP Wireless Assistant [uninstalled & re-installed, tried to uninstall HP Wireless Assistant 1.01 B2 also, but couldn't, however, now that's gone too]
    Intel(R)PROSet/Wireless Software

    I think the last one did the trick. Intel(R)PROSet/Wireless is now managing my wireless connection, before it was something else, maybe HP Wireless Assistant, but at least it's working fine now.

    Attached Files:

  12. On edge

    On edge Corporal

    Final update (unless anyone has questions): My NDIS Usermode I/O Protocol (ndisuio.sys) had been disabled, which is probably why the Wireless Zero Configuration wouldn't start. It was the root of the problem, even though I got around by installed all those other wireless utilities; or Intel PROSet/Wireless in particular.

    I found this out when I started going through my drivers with a freeware utility called DriverView, which is available here. AnVir Task Manager Free was also helpful, though be careful if you try it - it may turn off your protection programs...

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds