1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ipconfig: Media Disconnected

Discussion in 'Hardware' started by g.mac, Nov 19, 2005.

Thread Status:
Not open for further replies.
  1. g.mac

    g.mac Private E-2

    I’ve done some extensive google searching and also searched this forum, but I have not found any fixes that have worked for me.

    I have a dell laptop latitude D610 with windows xp/home sp2 connecting through a wireless broadband linksys router. It’s been working fine for months, but last week while using the internet, I suddenly lost my connection and was not able to reconnect. I did not make any changes or download any files while using it. My dad’s wireless laptop can still connect to the network without any problems. I am also able to connect to the network at my college apartment, just not here at home.

    After the problem first occurred, a cmd ipconfig showed an ip address of It now says “Media State . . . . : Media disconnected.”

    Some of the things that I’ve checked/tried: DHCP is enabled, Wireless Zero Configuration is enabled, TCP/IP set to obtain an IP address automatically, I turned off all firewalls and antivirus, I ran LSPFix.exe and WinsockFix.exe, ipconfig /renew and /release did not work, ipconfig /flushdns and then netsh winsock reset did not work, and I can also ping the local host but not the router.

    Any help or suggestions anyone can give would be greatly appreciated.
  2. majinbuu

    majinbuu Corporal

    tried rebooting the router?

    turn it off for five minutes then turn it on again and see what happens

    Also, are you using static or dynamic ip's for your network
  3. RayGavel

    RayGavel Private E-2

    Found this via Google, but only works if you know the MAC address of the router:

    Another solution suggested this:


  4. majinbuu

    majinbuu Corporal

    tried a different cable?
    old ones can become defective
  5. g.mac

    g.mac Private E-2

    Thanks for the suggestions. The mac address is already listed and I cannot repair the local area connection. Rebooting the router got my ipconfig message to change from “Media Disconnected” back to displaying the ip address and subnet mask both as I’m not sure if that’s an improvement or not. I haven’t tried a different cable, though the one now was bought only two months and our other two computers connect okay. I found a tech support number that I am going to call tomorrow if I can't get it fixed by then.
  6. majinbuu

    majinbuu Corporal

    you can try this:
    1) Go to a working machine and get its ip details - ie DNS, IP, SUBNET MASK and GATEWAY settings. Use ipconfig
    2) Go to the properties of your network card and manually assign the DNS, SUBNET MASK and GATEWAY to the same value as working computer
    3) Manually assign an IP address to your comp. make sure no other computers on your network are using it. To choose an ip address, get the ip from the working machine. Lets say its Make the IP on yours

    good luck :)
  7. g.mac

    g.mac Private E-2

    I manually assigned all the information. My wireless network connection window now shows me as connected, though i am still unable to access any sites. I used the ip details from the computer that is hard wired. I'm not sure if this makes a difference or not. I can check the details on the other laptop tomorrow morning.
  8. majinbuu

    majinbuu Corporal

    being a wireless connection, there is probably a password protecting the network. You'll need to know the password to get into the network. Some wireless products (i've owned more than one) say you are connected even though you have put the wrong password in. What happens then is that you cannot browse, which sounds like whats happening with you. Make sure you get the password and encryption type (WEP/WPA) right

    Make sure the assigned IP is different than any other on the network. DNS, Gateway and Subnet values are the same for all computers, IP is the only one that is diferent.

    Just say for arguments sake again that one computer on your network that works has an IP of only change the last set of 3 numbers (in italics) to get a new IP for the nonworking computer.

    On the network properties screen, are you sending and receiving many packets?

    Try to ping a working computer from the non working one, that will tell if you have basic network connectivity. You can do this by going to the same text interface on the nonworking machine where you type ipconfig and instead type ping xxx.xxx.xxx.xxx where you replace x's with the ip of a working computer.

    If this is as clear as mud to you, please let me know and we'll try it step by step.
  9. g.mac

    g.mac Private E-2

    -i entered the ip address and changed the last number(i tried a number 1 higher, 2higher, & 1 lower).
    -packets sent and received are currently at 3900 and 3200. I also noticed that it does not constanly stay connected. It says "connected" for about 30 seconds, briefly changes back to "automatic", and the quickly back to "connected"
    -i am unable to ping the working computer or vice versa.
    -i reentered what i believe(fairly certain, but not positive) is the correct password for the network key.
    -i don't know how to check the encryption type. On the wireless network connection window it says "Security-enabled wireless network (WPA)"
  10. majinbuu

    majinbuu Corporal

    ok, its good that you are sending and receiving packets, it means we are on track. As long as you are sending and receiving packets, leave the IP addresses alone for now.

    There are 2 things I believe are causing your connection problems right now.

    1) are you using windows wireless utility to manage the wireless connection, or are you using a third party software that comes with a wireless card? When you say it connects/disconnects/reconnects that can sometimes mean that the windows wiireless manager is conflicting with the third party wireless program. If that's the case, then go into your wireless connection properties which can be found thru the control panel, find a box like "allow windows to manage connection" and uncheck it which will allow your third party software to maintain the connection without interruption.

    2) You must make sure you are using the right network key and encryption type. Even though you can send and receive packets, it doesnt mean you have the password right.

    3) Oh, temporarily disable any firewall software on your computer while you perform these steps, but dont forget to turn it back on :)

    4) Make sure you have good signal strength. Put the computers about 5 meters apart. Not too close, that actually will decrease signal strength.
  11. majinbuu

    majinbuu Corporal

    If you are unsure whether you are using the right password, disable encryption on the router temporarily and see if you can connect. Be sure to re-enable encryption afterwards, and use the same key on the laptop.

    Got any wireless devices causing interference, bluetooth, microwaves and cordless phone wreak havok on wireless networks
  12. g.mac

    g.mac Private E-2

    I unclicked the box allowing windows to manage my connection. When I did that a program popped up in the system tray: Intel PROSet/Wireless. I've never (knowingly) used this before-or rather i've never seen this window. Anyway, it says I am connected to my network. It is not disconnecting/reconnect. Signal quality listed as excellent. I still cannot access any websites. I am fairly certain i have the right network key but how do i check encryption? Under the security settings in this Intel window there is an option for data encryption and a dropdown menu with the choices of WEP, TKIP, and AES - CCMP. It is currently set to TKIP. I don't know what any of these mean or which i should be using.

    P.S. If your still on, its nearly 3am my time, i'll be going to bed soon, thanks for all your help so far. :)
  13. majinbuu

    majinbuu Corporal

    what ya gotta do is go into the wireless router configuration pages and look at how the wireless security is set up. There are a few combinations of wireless security like WEP, WPA, TKIP, WPA-PSK etc... You have to match them on both the router and your wireless card for it to work. The most probable setting is WPA-TKIP. Try using that one. Otherwise spend some time trying different ones ie WEP.

    It's good that the Intel PROSet/Wireless app popped up, we can work with that.Do all your changes in that app.
    Can you do anything on the net, emails, messenging etc...?? with that comp.

    If we can't settle this on the forums, maybe we can talk through messenger, I've sent you a PM with my user name.

    I think you're about 14 hrs behind me :)
  14. majinbuu

    majinbuu Corporal

    just continue trying to do what I said, try using some apps like messenger, email etc...
    try going into the text box where you did the ipconfig and type ping and see if its successful and we'll talk again tomorrow.

    Double check your firewall, it may be causing some of the problem. What are you using by the way?

    Also for the wireless security encryption, try WPA-PSK with TKIP algorithm, its the most common
  15. majinbuu

    majinbuu Corporal

    another thing, can you get access to the wireless router configuration menu. The IP address for it should be the same as the GATEWAY address we discussed earlier. Have a look around, particularly for things like:
    1) encryption type
    2) Infrastructure or Ad-hoc
    3) preamble type - can play around a bit with this, longer ones seem to work better sometimes
    4) See if MAC filtering is enabled
    5) Have a look in the router event log, it may give some insight into the problem

    Thats it for me today :)

    I'll be back around 12pm my time
  16. g.mac

    g.mac Private E-2

    Turns out this was the problem. I can now connect and browse,message,etc. I'm not sure how I lost the connection/network key to begin with, but instead of entering the network key, I was entering the administation password for the router. It's a little annoying now that it was something so simple :rolleyes:. When I tried to connect today, the PROSet/Wireless app said there was was an incorrect network key. It would have saved me/you alot of trouble if the Windows utility gave this message. Thank you for all the help. :)
  17. majinbuu

    majinbuu Corporal

    It was no trouble at all :)

    I do this as much to help people as to increase my own knowledge.

    Yeah, the Microsoft wireless manager is really bad when it comes to the problem of an incorrect key. It says you are connected and you can receive packets but you aren't actually connected in such a way as to browse, email etc...

    That's why I was happy when you said the PRO/SET Wireless app was on your comp, it actually tells you when you have put in the wrong key. Why microsoft can't follow suit, who knows?
  18. neo_granas

    neo_granas Private E-2

    I'm having the same trouble. My girlfriend's laptop wasn't able to connect to the wireless network at my apartment so I was stupid and for whatever reason thought she was caching DNS so I flushed it. I guess I flushed more away because now I get the Media Disconnected message when I use 'ipconfig' in command prompt. I have tried renewing, double checking keys, rebooting, anything I can think of. I know it's not the router needing a Mac address because it's a temperamental NetGear from my upstairs neighbor that doesn't allow me to input Mac addresses without the wireless device already trying to connect. The system tray icon for wireless is not moving so I don't know what to do. Any ideas?
  19. Davey101

    Davey101 Private E-2

    Old thread I know, but I was so gratefull to fix my problem, I thought I'd reply:)

    After loads of googling, trying loads of settings, reinstalling XProlleyes ip this and that, I read Majinbuu's post, suggesting, among other things to make sure that the security key was correct.
    Turned out this was the problem, I'd been entering the wrong key (by one digit).

    Why it lets you think that you have entered the correct key, I have no idea, but without reading that post, I wouldnt have got it fixed any time soon.

    I'm off to have a beer to celebrate, cheers mate!:major
  20. majinbuu

    majinbuu Corporal

    Enjoy your beer, glad my old post was able to help :)
Thread Status:
Not open for further replies.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds