1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Laptop connects locally, but not to internet

Discussion in 'Hardware' started by crimsonthread, Jun 16, 2011.

  1. crimsonthread

    crimsonthread Private E-2

    Since I replaced my parents' dead router a month ago, my mom has not been able to connect to the internet wirelessly with her laptop. My dad's laptop and their desktop have no problem connecting. With hers, it will connect locally, but not to the internet. Her laptop works fine at my house and if I connect it directly to their modem. Any ideas about why this might be happening? I've included basic info about the modem, computer, and router below, and can provide more detailed info tomorrow if needed. Thank you!

  2. iain.t

    iain.t MajorGeek

    Hi crimsonthread,

    Do this to flush the DNS Cache

    1. Click the Microsoft Vista Start logo in the bottom left corner of the screen
    2. Click All Programs
    3. Click Accessories
    4. RIGHT-click on Command Prompt
    5. Select Run As Administrator
    6. In the command window type the following and then hit enter:
    ipconfig /flushdns
    7. You will see the following confirmation:

    Windows IP Configuration
    Successfully flushed the DNS Resolver Cache.

    Do this to show the ip configuration set up

    1. Click the Microsoft Vista Start logo in the bottom left corner of the screen
    2. Click All Programs
    3. Click Accessories
    4. RIGHT-click on Command Prompt
    5. Select Run As Administrator
    6. In the command window type the following and then hit enter: ipconfig /all

    Please write down the settings in there and post them here for me to have a look at.

    Also remove the the wireless set-ups in the Network and Sharing centre....

    1. Click the Microsoft Vista Start logo in the bottom left corner of the screen
    2. Click Control Panel
    3. click Network and Sharing centre
    4. click Manage Wireless Networks
    5. Delete all of the Connections in there by clicking on them then click remove
    6. Re-start your computer and scan for wireless network connections

    I hope this is of some assistance please post back the results.

    iain.t :major
  3. handygal

    handygal Sergeant Major

    I would start even simpler.

    Look in the wireless nework settings for your dad's laptop. In the Internet Protocol TCP/IP properties check if it is set to - Obtain and IP Adress automatically. Go to the same place in your mom's laptop and make sure it has the same setting.

    If the functioning laptop has any other setting in the TCP/IP properties, the steps to correct will be slightly different.
  4. crimsonthread

    crimsonthread Private E-2

    Thanks for the ideas, guys.

    @Handygal--My dad's laptop runs Windows 7, and I'm not familiar with that OS yet. How can I get to the wireless network settings there? In the meantime, I'll go ahead and try iain.t's ideas. Thanks!
  5. crimsonthread

    crimsonthread Private E-2

    @Handygal--Found it on both computers, and all settings are the same.

    @iain.t--I followed your steps, and am attaching screenshots of the ipconfig/all results.

    I'm still not able to connect on her computer. Thanks again for all your help!

    Attached Files:

  6. handygal

    handygal Sergeant Major

    Your mom's laptop isn't connecting with the router, it's not getting an ip, and I have an idea of what happened.

    Did you name the new network the same as the old one with the same password? You have to delete the entry in the saved wireless networks and re-enter it with the SSID and password again. There is a Vista walk-thru here You want to manage the connections and then remove the one that you are trying to access.
  7. crimsonthread

    crimsonthread Private E-2

    Thanks for the info, but I did change the network's name. The password is the same as before. I also deleted all the saved networks, as iain.t recommended, and tried to re-connect after that. I'll try deleting it again tomorrow, just to be sure, but in the meantime, do you have any other suggestions? I really appreciate all your ideas!
  8. techsent

    techsent Corporal

    hey crimsonthread,

    with her laptop turned on, turn off the 2wire modem. pull the plug on the router. turn the modem back on and wait til the lights are established. plug in the router and wait til the lights are established. on her laptop, disconnect from the router. reconnect to the router. wait a few seconds and attempt to browse the net.

  9. crimsonthread

    crimsonthread Private E-2

    @Techsent--I may have tried that already, but not necessarily in that order. I'll give it a shot tomorrow. Thanks!
  10. handygal

    handygal Sergeant Major

    Oh hey, i should have looked a little more closely. iain.t is good, i should have assumed that was already suggested.

    On the laptop, can you run the ipconfig/all command and post the results here of the connection that is active please. The most important will be

    DHCP Enabled
    IPv4 (or just IP Address)
    Subnet Mask
    DHCP Server
    DNS Server

    Also, i just thought of something with the wireless configuration. Do you have a smart phone or any other device that can connect wirelessly and sees the internet? Perhaps the wireless side of the router is not set properly. The numbers from the ipconfig/all might show that though.
  11. crimsonthread

    crimsonthread Private E-2

    @Techsent--Tried your ideas, no luck.

    @Handygal--Dad has a tablet that he connects to the wifi network here, and I occasionally connect with my ereader. Here's the info for the "Wireless LAN adapter Wireless Network Connection:"
    DHCP Enabled: Yes
    IPv4: (preferred)
    Subnet Mask:
    Gateway, DNCP server and DNS server are all
  12. handygal

    handygal Sergeant Major

    When that computer gets the IP what is the ip on the computer that works?

    I don't want to bash an OS (much) but I had a problem with my only Vista tablet that I never did solve. Hours of tech support and fiddling and it never went wireless. Ethernet was fine on mine too. I'm not a fan of vista. That doesn't fix you now though. If there is no IP conflict, no wireless driver update and no service that is failing in the administrative tools then I'm at a loss at the moment.
  13. handygal

    handygal Sergeant Major

    one more thing.

    at the command prompt, run the commands

    ping google.com

    Do they both time out?
  14. crimsonthread

    crimsonthread Private E-2

    On my parents' desktop, the IP is, and my dad's laptop is

    When I ping, it times out, then gives me some info:

    Ping statistics for
    Packets: Sent=4, recieved=1, lost=3 (75% loss)
    ...and then some other stuff I can provide if needed (but it's a lot, and I don't want to type it out unless necessary.)

    When I ping google.com, I get: "Ping request could not find host google.com. Please check the name and try again."

    I know Vista gets a lot of grief, and I had issues with it on my old laptop. However, everything works great on my current laptop with Vista; unfortunately, upgrading to 7 is impractical for my mom's computer. If you have any other suggestions, I'd be greatly appreciative, but if not, I understand. My next step is to try (again) to call the AT&T internet support... :shudder:
  15. handygal

    handygal Sergeant Major

    I didn't expect those results.

    maybe someone else can shed some light on why a ping to a dns is getting 1 of 4 replies and google.com got none. You might have to try the test a few times to see if that is fairly consistent.
  16. crimsonthread

    crimsonthread Private E-2

    I tried it several more times. Sometimes it gets 2/4 replies, but never more than that.
  17. handygal

    handygal Sergeant Major

    Do you happen to have an external usb wireless modem? A desktop that you put a usb wireless on and could borrow for testing? I'm thinking there is a conflict or a vista compatibility issue.

    You're thinking I'm crazy right now, that it's the OE wireless card and it's vista certified but it's worth a try to isolate the issue to the computer and not AT&T. If the usb works you also have a work around.
  18. crimsonthread

    crimsonthread Private E-2

    I'm not sure if this is what you mean, but they do have a USB wireless card that they use for an old desktop that doesn't have an internal card. If that's not what you're talking about, could you give me a link to such a product on Amazon or something similar so I know what to look for?
  19. handygal

    handygal Sergeant Major

    that's it, I've also seen it called a dongle. It's definitely worth installing on the laptop and testing.

    And my error, it's not a usb wireless modem, it's an adapter. If you look in Amazon for usb wireless adapter, that's what I'm referring to. (link was ridiculously long)
  20. crimsonthread

    crimsonthread Private E-2

    Ok, I'm on my way over to try it now. :)
  21. crimsonthread

    crimsonthread Private E-2

    Unfortunately, the dongle thingy doesn't work well anymore, and I don't have the installation software to put it on her computer. I don't know if it's worth it to spend $30-80 on a new one just to see if it works, but if that's the only route left, I'll give it a shot.
  22. crimsonthread

    crimsonthread Private E-2

    I found another wireless network adapter and installed it, and I'm able to connect to the internet that way. Does this give any other reason for the problem? If there's no known solution, that's fine, as long as she's able to get online, but this is almost a personal thing now and I feel like I won't be satisfied until I find out WHY it's not working. Thanks again for all your help. :)
  23. handygal

    handygal Sergeant Major

    Sorry for the long delay, connection was down.

    I know what you mean about it being personal now. I scanned through the thread quickly, did anyone mention updating the drivers for the wireless card? I'm glad the dongle worked and it's probably enough to leave it alone. It could be compatibility, card going bad, update needed, quirk of computer brain. Probably another 20 reasons too.
  24. crimsonthread

    crimsonthread Private E-2

    Shouldn't be the card, since it works at my house... I'll probably just have to let this one go and be happy the adapter works. :)

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds