1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Limited or no connectivity...What's up?

Discussion in 'Hardware' started by Kiholo, Jul 13, 2007.

  1. Kiholo

    Kiholo Private First Class


    With the help of Chaslang in the Malware forum, I just got my son's laptop clean and functional again. However, one of the remaining problems is no internet connectivity. I don't know if this is a hardware (NIC driver) or software (TCP/IP et.al.) problem.

    Here are a few symptoms/observations:
    1. Can't connect to internet
    2. Local connection icon in tray is overprinted with a yellow caution sign; when I click on it the General Tab indicates:
    Connection Box:
    a. Status: limited or no connectivity
    b. Duration: clock ticking
    c. Speed: 100.0 Mbps
    Activity Box:
    There is a caution sign between the display icon and the network icon; packets sent = 9; received = 0

    TCP/IP properties is set to Obtain IP address automatically.
    3. Via command prompt ipconfig, the response reads:
    Connection-specific DNS Suffix: No entry
    Autoconfiguration IP Address:
    Subnet Mask:
    Default Gateway: No entry

    FYI: The laptop I am using now responds to the same command as:
    Connection-specific DNS Suffix: Belkin
    Autoconfiguration IP Address:
    Subnet Mask:
    Default Gateway:

    I would appreciate any help.


  2. dedub

    dedub Corporal

    Kiholo, this seems easy.

    The 169.254.X.X is Microsoft's way of telling you that it looked for a DHCP server to give it an address and could not find one. That IP is a failed attempt. The Yellow symbol means pretty much the same thing.
    My guess is your hardware is fine. The 9 packets that were sent out tells me that it's working properly.

    1. Check your cable if your using cat-5. (do you have a link light?)
    2. if its wireless, ensure you have ALL the setting, like the SSID and WEP or WPA key if it's encrypted.
    3. Is your router even set up to issue an IP or is your the laptop your using now set for a static IP
    4. Try setting the IP on your sons statically, ie.... and
    5. Always remember the most useful tool offered by M.S..... PING!
  3. Kiholo

    Kiholo Private First Class


    Thanks for contributing and providing some answers, i.e., identifying the DHCP server, etc.

    I'm using a wired connection; my home is Cat-5 wired. I know the connection is good cause I've used it and the same patch cable to connection a working laptop. The working laptop is using DHCP so the router appears to be providing IP...also have other desktops connected to the router and switches in the cabinet.

    With regard to inputting a static IP, I have tried that as well but to no avail...still no connection.

    Since I don't have the recovery disk for his laptop, I'm somewhat reluctant to uninstall and reinstall the TCP/IP component...but the bigger thing is I am not sure of the correct steps to do it...uninstall and reinstall.

    I need to tell you that this laptop was just cleared and brought back to life after being infested...really infested with all sorts of malware...so I'm wondering if one of the problems was a result of that.

    Any assistance and thoughts/suggestion on troubleshooting are welcomed.

  4. Kiholo

    Kiholo Private First Class


    Chaslang provided me with a TCP/IP repair application and that did the trick! Thanks for your help.


Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds