1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

lost administrator rights on Windows XP

Discussion in 'Software' started by jizaref1, Dec 19, 2010.

  1. jizaref1

    jizaref1 Private First Class

    I am using Windows XP MCE SP3. For computer issues recently detailed in another thread, I needed to do a reinstall of my OS. I did it clean over the other install, without an entire HD wipe.

    Things are working much better now, without startup errors and a faster system.

    I have only one default user account, under my name, with full adminstrator rights assigned. But I am still getting an occasional error message when I try to change or delete some things, and I don't know why or how to change it. It even happens in Safe Mode.

    Three example:
    1. When I try to startup up iTunes it tells me "The iTunes library file cannot be saved. You do not have enough access privileges for this operation." So I cannot download new apps or save files into that folder.
    2. I have a bookmark on IE8 saved to my Favorites bar. I wanted to remove it and when I right click and select delete I get the message "Cannot delete [bookmark name]. Make sure the disk is not full or write-protected and that the file is not currently in use."
    3. I moved some files into a new folder by drag and drop. Now when I go to delete the files or the folder, Windows tells me: "Cannot delete [bookmark name]: Access is denied Make sure the disk is not full or write-protected and that the file is not currently in use."

    Any thoughts on how to get full admin and editing access to my own OS?

    I already ran MBAM and SAS to be sure it wasn't malware.

  2. mcsmc

    mcsmc MajorGeek


    The first thought that comes to mind is that you have the NTFS file permissions set from your previous installation.

    Try navigating to C:\ and right click Program Files, select the Security Tab, then Advanced, and Take Ownership. MAKE SURE that "apply to subfolders/files" checkbox is checked, and then click Apply. It will likely take awhile to complete. Do NOT interrupt the process, or the permissions could get really messed up. Also, take my instructions in a general manner, as I don't remember all of the specific wording used in the XP security settings process.

    Once you have taken ownership, close out the Security settings window, and re-open it, and ensure your Windows account user name is listed (if it's not, add it), and set permissions to Full.
  3. sach2

    sach2 Major Geek Extraordinaire

    If you don't see the Security tab then you have to follow these steps first to make it visible.

  4. mcsmc

    mcsmc MajorGeek

    Thanks, I forgot about simple file sharing!
  5. tgell

    tgell Major Geek Extraordinaire

    sach2, I may be mistaken, but isn't MCE based on XP Home? If it is, then the only way to see the security tab is to log in to the administrator account in safe mode or use a software hack.
  6. sach2

    sach2 Major Geek Extraordinaire

    I'm pretty sure MCE is Pro with Media Centre.
  7. mcsmc

    mcsmc MajorGeek

  8. Earthling

    Earthling Interplanetary Geek

    Correct -

    Attached Files:

  9. tgell

    tgell Major Geek Extraordinaire

    Thanks guys. :)
  10. Puppywunder58

    Puppywunder58 Master Sergeant

    On an unrelated topic to this one I want to apologize to Sach2 and give you a great kudo for the tireless, time consuming work you did with the OP regarding the Lenovo laptop.
  11. TimW

    TimW MajorGeeks Administrator - Jedi Malware Expert Staff Member

    Reset Registry and File Permissions

    The below is based on original info from http://support.microsoft.com/kb/949377

    Important: This task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

    How to back up and restore the registry in Windows]

    1. Download and then installSubInACL (SubInACL.exe)file from Microsoft.
    2. Click Start, Run and enter notepad and click OK to bring up the Windows Notepad program.
    3. Copy and then paste the following text into Notepad.

    cd /d "%ProgramFiles%\Windows Resource Kits\Tools" 
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
    subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
    secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose
    4. Save this Notepad file as Reset.cmd to your desktop. Be sure the Save as type is set to all files.
    5. Once you have save it properly, double-click the Reset.cmd file to run the script.

    * Note This script file may take a long time to run. Additionally, you have to run this script as an administrator.

    6. Now reboot your computer! You must do this before the above will take effect.
  12. jizaref1

    jizaref1 Private First Class

    So before doing that notepad registry suggestion, I did the prior suggestion and it definitely helped! Thanks so much!! I am able to download iTunes apps and delete some subfolders I was unable to previously. The only thing I currently wish to do (minor) is delete an Internet Explorer Favorites Bar shortcut where I am getting that same message.

    Should I still proceed with the registry edit, as I am always wary of major changes with so many warnings attached.
  13. mcsmc

    mcsmc MajorGeek

    Yes, that registry fix looks like it should take care of the entire computer, fixing any remaining permissions issues.
  14. jizaref1

    jizaref1 Private First Class

    How can I be sure I am running it as administrator, there is no right click option to select.
  15. mcsmc

    mcsmc MajorGeek

    Right clicking to run as administrator is only on Windows Vista and Windows 7.

    To run as administrator on Windows XP, you simply need to be logged into a user account with administrator privileges, which shouldn't be an issue for you, as the user account you created has administrative privileges.
  16. jizaref1

    jizaref1 Private First Class

    Trying to rum the Reset.cmd now and I get:

    C:\>cd /d "C:\Program Files\Windows Resource Kits\Tools"

    C:\Program Files\Windows Resource Kits\Tools>subinacl /subkeyreg HKEY_LOCAL_MACH
    INE /grant=administrators=f /grant=system=f
    'subinacl' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Program Files\Windows Resource Kits\Tools>subinacl /subkeyreg HKEY_CURRENT_US
    ER /grant=administrators=f /grant=system=f
    'subinacl' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Program Files\Windows Resource Kits\Tools>subinacl /subkeyreg HKEY_CLASSES_RO
    OT /grant=administrators=f /grant=system=f
    'subinacl' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Program Files\Windows Resource Kits\Tools>subinacl /subdirectories C: /grant=
    administrators=f /grant=system=f
    'subinacl' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Program Files\Windows Resource Kits\Tools>subinacl /subdirectories C:\WINDOWS
    \*.* /grant=administrators=f /grant=system=f
    'subinacl' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Program Files\Windows Resource Kits\Tools>secedit /configure /cfg C:\WINDOWS\
    repair\secsetup.inf /db secsetup.sdb /verbose
    Completed 9 percent (407/4093) Process File Security area
    [only this last part seems to be running]
  17. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    Not completely correct. In Win XP, you can right click and select Run As. And then choose the user you wish to run as. Entering Administrator and the password will run as the Administrator.
  18. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    Does the below folder exist?

    C:\Program Files\Windows Resource Kits\Tools

    In the above folder, does the subinacl.exe file exist?
  19. jizaref1

    jizaref1 Private First Class

    I reinstalled just to be sure and confirmed it is there.
    I ran Reset.cmd again from the C:/ folder where I confirmed I have owner and Admin rights as an added user.

    It runs through the black Cmd window rapidly and then opens a red-colored smaller Cmd windows where it is running through system files/processes one by one. It is keeping count and listing them all as Failed.
  20. mcsmc

    mcsmc MajorGeek

    True. I wasn't awake when I wrote that post. I MEANT that on an administrator account, you only need to use the right click, run as Admin, on Vista and 7. Thanks for the clarification for the OP.
  21. jizaref1

    jizaref1 Private First Class

    When I right click other program I get that "Run as..." option and can choose administrator with password. When I right click the Reset.cmd file I do not get the secondary login option, even when that service is enabled and started. I tried taking ownership of C:/ and adding myself as Full access user as suggested above, but I still get the red window with Failed when running it by double clicking.
  22. sach2

    sach2 Major Geek Extraordinaire

    I didn't want to get in the middle of troubleshooting running the script but I would think that if you just want access to IE favorites then taking Ownership of Drive C: as you successfully did for Programs folder should give you access. Have you tried deleting the bookmark/favorite in IE8 after taking ownership of C:?
  23. jizaref1

    jizaref1 Private First Class

    I did take ownership of C: already in case that was the issue. Same problem exists. So I was wondering if problems running the script was symptomatic of a larger issue, especially because I should own all of it. Any other reason for that Failed notice in the red cmd window?
  24. sach2

    sach2 Major Geek Extraordinaire

    I've never had to run a script to get access to folders but I think we should wait and let TimW troubleshoot running the script. He knows more than I do on permission issues. Maybe there is a simple reason that the Reset.cmd file isn't completing successfully.
  25. mcsmc

    mcsmc MajorGeek

    I believe (and could be wrong) that taking ownership of a drive does NOT automatically transfer the ownership to folders on the drive. However, taking ownership of a folder will take ownership of subfolders and files within that folder, provided the "apply to subfolders, etc." is checked.

    You may have to take ownership of every folder listed in C:\.

    As to the script, I agree that TimW should be the one to comment on that, as personally I'm clueless as to why it's not working.
  26. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    Right click on subinacl.exe and select Properties. Then look at the Security tab and see who has been allow to have Full Control with it. Look at each of the Group or user names: items

    Also check to see which groups/users have Read & Execute permissions
  27. jizaref1

    jizaref1 Private First Class

    So I verified that I am the primary owner of C:, Windows folder, Program Files folder, and even Tools under Windows Resource Kits. I also checked Properties as suggested for the subinacl.exe and my Reset.cmd and I am Owner, Full edit access, and even opened Full privileges to all users including myself and Administrators to make sure there is no block.

    When I run the Reset.cmd I still get the second red tinted command windows running through a count of "Modified" and "Failed" for all changes, and then the program runs again when it reaches the end.
  28. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    Click Start, Run and enter cmd and click OK. This will open a command prompt window. In the command prompt window enter the below commands in bold black print. The purple is just questions or informational. Note the space after the cd

    cd C:\Program Files\Windows Resource Kits\Tools\

    This should change folder so that your prompt becomes the below
    C:\Program Files\Windows Resource Kits\Tools>

    Is this what you now have for a prompt. If yes, enter the below command and hit enter. Note the space after subinacl

    subinacl /?

    Did you receive a bunch of help information about the subinacl command?
  29. jizaref1

    jizaref1 Private First Class

    Yes I did
  30. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    Okay then this likely means that the error message you received is only because it cannot find subinacl.exe in your path for some reason. Let's try the following:
    • Download and save the below to your PC. Make sure that you save into the C:\Program Files\Windows Resource Kits\Tools\ folder where I just had you run the command prompt test from.
    • Then if you already closed the command prompt window, reopen it and cd back into that same folder again.
    • Make sure that the prompt line shows C:\Program Files\Windows Resource Kits\Tools> so that you know you are in the correct folder.
    • Now type the below command and hit enter
      • Permfix.bat
    The above should run the file you just downloaded and save to this folder. Did you get any error messages? If no, then reboot your PC and see if this helped your permissions problem.
  31. jizaref1

    jizaref1 Private First Class

    So I am not sure I am getting an error message, but what should the output of this command look like?

    First a series of white on black text ran very rapidly through the command window.

    Then a second cmd window with a red/maroon header opened and it is running through a series of HKEY registry entries with the top line reading like this: "Done: 88003, Modified 88000, Failed 3, Syntax errors 0."
    Are those true failures, or errors, or is that what the output should be?
  32. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    Just reboot your PC and see how things are working. See if the problems you were trying to resolve have been resolved.
  33. jizaref1

    jizaref1 Private First Class

    So I did as directed and things are the same. I am not even sure it is a problem but suggests an issue with ownership?

    All other folders and files can be modified.
    But when I am using Internet Explorer 8 and trying to delete a single bookmark (actually it is a bookmark of a prior Major Geeks thread), I still get the error message:

    "Cannot delete [bookmark name]. Make sure the disk is not full or write-protected and that the file is not currently in use."

    Should I even worry about this if everything else seems to work OK?
    Interestingly when I add myself as a user and owner with Full access privileges, sometimes Administrators is still listed but I need to add my specific name again. Does this mean anything?
  34. jizaref1

    jizaref1 Private First Class

    If it is at all meaningful or helpful, attached is the output log of when I ran the cmd.

    Attached Files:

  35. jizaref1

    jizaref1 Private First Class

    I just noticed now since the restart and running that command that my antivirus (ESET NOD) is broken. When trying to start the service I get an error: "Could not start the service on Local Computer. Error 5: Access is Denied."
  36. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    I would not waste anytime on it. This happens sometimes and it is not a permissions issue. Sometimes it is just file corruption or something in the name of the file ( file name corruption ).

    Add yourself to what and where?
  37. jizaref1

    jizaref1 Private First Class

    I think all is fixed now. Something was happening funny with ownership of the files. So I did a system restore back to before I ran all of these suggestions. I started from scratch and only took ownership of the Program Files folder. Then I ran Permfix.bat and it now all seems right, including the ability to delete that corrupt bookmark.

    In the future, what is the proper ownship privileges that I should assign?As suggested earlier in this thread, I turned off folder sharing, and assigned myself as the owner of Program Files. I then made sure my User name was added to the list of access users with full privileges. This was on the Sharing and Advanced tabs. It seems when I tried to do the same for C: and Windows and all of its subfolders that is when ESET and iTunes and a few other things started to misbehave.

    So another follow-up question on this, which might need a new thread: since ESET was behaving strangely I uninstalled the entire thing with a plan for a clean install. I happened to notice since I did the uninstall (but not yet reinstalled) that the system is running a teeny bit speedier and that up Verizon FiOs upload speed is much improved. I am paying for 25/25 and was getting 25/8 consistently with NOD running. Now I am back to 25/21-24. Is ESET NOD known to slowdown a system or file upload speed that significantly or should I troubleshoot some more?
  38. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    You should not be changing them at all. If you have been changing permissions of folders that the System requires to be set a certain way, you could be the source of your own problems. Windows requires the Administrator ( this is a unique account. It is not your account ) and System, Power User accounts to be set in appropriate ways to not interfere with normal system operation and to not interfere with other software that you may need to install and run. I cannot tell you how to set the permissions for the hundreds of folders that exist. All I can say is you should not be changing them.

    Sharing files and folders does complicate things a little but folders like \Windows and \Program Files and quite a few others should not be shared anyway.

    Yes as I stated above..... you are the one who caused the problem.;)

    Yes you should post in another thread. All I will say here is that every protection type program you install, will have an impact of system performance as well us throughput tests.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds