1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No admin rights win7

Discussion in 'Software' started by flamewolf393, Apr 29, 2012.

  1. flamewolf393

    flamewolf393 Private E-2

    I am using windows 7, and starting yesterday I have been unable to install or uninstall ANYthing. In fact I cannot access anything that requires admin rights. There is only one account on my laptop, and it is an admin account. I cannot access services, system restore, regedit, or UAC. I have tried downloading various fixer files/programs, but I cannot launch them because unknown files require admin acknowledgement. I can still run programs that are already installed like firefox and my various games. I do not get error messages (except once), things just dont run, or the process starts and just spins.

    I am fairly certain the problem is occurring around the consent.exe process., and at one point I had the infamous "Too many files are in use by 16 bit programs" error.

    COMPUABLE First Sergeant

    >> I am using windows 7, and starting yesterday I have been unable to install or uninstall any thing. In fact I cannot access anything that requires admin rights. flamewolf393 <<

    My first suggestion would be to try to restore your computer to an earlier time (before yesterday, preferably) using the Windows System Restore tool. Additionally, since you apparently had administration rights before yesterday, you should run a full virus check using your computer's antivirus program (as well as a full malware check) to check for any possible nasties. After you have completed the virus scan and malware check; follow the steps listed below and you will be able to regain access, total control and be the owner of the Windows 7 operating system, including its tools and apps.

    How to Get Full Administrator Rights in Windows 7:

    1) Click Start.
    2) Click Computer (you might also find this icon on the desktop).
    3) Right click on the Hard Disk icon where your OS is installed on and click Properties.
    4) Click the Security tab.
    5) Click the Advanced tab.
    6) Click the Change Permissions button located after the Permission Entries list.
    7) A new window will appear on your screen; which contains a list of all the User Accounts available on your computer.
    8) Select the user account you want to give total control over your Windows 7) and click the Edit button.
    9) Now, tick the checkbox labeled "Total Control" and press OK.

    You're all done! ;)

    Side Note: As a precaution; you might want to copy these instructions to a .txt document or copy and send them to yourself in e-mail them before proceeding with the steps listed above.

    Good Luck! -- COMP​
  3. flamewolf393

    flamewolf393 Private E-2

    I cannot access system restore as that requires admin access. I have avira, and it says I am clean. I am unable to install any other malware programs because installing requires admin access.

    Cant do step 6. The change permissions button requires admin access.

    I kinda see a pattern developing her...
  4. plodr

    plodr Major Geek Super Extraordinaire

    Boot into safe mode and login using the hidden admin account. You will need to know the password you used when you set up the computer.
  5. flamewolf393

    flamewolf393 Private E-2

    I have tried that. There is not a hidden admin account. Mine is the only account on the computer. The store I bought it at set up the accounts for me, asking what I wanted for name and password, I am thinking they screwed something up and disabled the default admin account.
  6. tgell

    tgell Major Geek Extraordinaire

    Windows 7 disables the built in Administrator account by default. Go into safe mode with command prompt. Then type the following command.

    net user administrator /active:yes

    Reboot the computer.

    Edit: sach2's answer is better than mine. :)
    Last edited: Apr 29, 2012
  7. sach2

    sach2 Major Geek Extraordinaire

    The hidden admin account is disabled by default in Win7.

    Try going to the Start menu and type in cmd into the Search box but don't hit enter. When you see cmd.exe in the search results right click it and select Run as Administrator. Then paste net user administrator /active:yes into the command prompt and then close the cmd window. Logoff and see if the Administrator account is now visible on the Welcome screen.

    Also take a quick look at C:\Users folder and see if there are any strange named folders like instead of just having a folder for your username like John, if there is a folder named something like John.00001 also. That would indicate a corrupted user profile.
    Last edited: Apr 29, 2012
  8. flamewolf393

    flamewolf393 Private E-2

    Well thats one step closer, now how do I find out what the password is for the default admin account? The "reset password" option says its need removable media... Btw I had to use tgell's way since I CANT run things as admin.

    This default account has never been active before, so it's not like I just forgot the password, one has never actually been set for it. I am hoping that there is just a default password.
    Last edited: Apr 29, 2012
  9. sach2

    sach2 Major Geek Extraordinaire

    Does it take just leaving it blank and hitting enter?

    Do check C:\Users for an oddly named folder with your username to help determine if your original profile is corrupt.
  10. flamewolf393

    flamewolf393 Private E-2

    Nope, and theres only default, my account, and public.
  11. tgell

    tgell Major Geek Extraordinaire

    Not sure if this would work but try this at the command prompt.

    net user administrator *

    This will prompt for a new password.

    When you say public account do you mean guest account? Did you create an account called public? If you did not then I would think this may be a malware issue.
  12. _nullptr

    _nullptr Major Geeky Geek Geek

    I think the OP means C:\Users\Public, C:\Users\Default
  13. tgell

    tgell Major Geek Extraordinaire

    Thanks _nullptr. lol AADD strikes again. :)
  14. flamewolf393

    flamewolf393 Private E-2

    Well, I have gained access to the default admin account, also made a new admin account just to be safe, and managed to get the malware tools I wanted installed and running, but I still cannot access any of the admin tools like UAC, or the right click -> run as admin command, and the scans only found a couple minor items. So I am still stuck.
  15. tgell

    tgell Major Geek Extraordinaire

    I would go to the Malware Removal Forum and attach the appropriate logs as listed in the sticky posts. They may find something that was missed. If not, come back here and we will continue on.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds