1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No more sound on Dell Latitude D820

Discussion in 'Software' started by erodrigue, Jul 15, 2008.

  1. erodrigue

    erodrigue Private E-2

    Hi there,

    I am new to this forum.

    I have a Dell Latitude D820 laptop running Windows XP SP2. 1-2 months ago, the sound suddenly stopped on it. I don't see the volume control in the tray anymore. Any application needing sound complains there is no sound board installed.

    Device Manager shows yellow exclamation marks right besides "SigmaTel High Definition Audio CODEC" and "Microsoft Kernel System Audio Device". I have tried many things:

    - Uninstalling/reinstalling both
    - Scanning PC for viruses (Symantec Corporate) and Spyware (Checkpoint Integrity)
    - Running a Windows repair install
    - Running sfc /purgecache followed by sfc /scannow
    - Booting in safe mode and replacing the c:\winnt\system32\drivers\sysaudio.sys file with a file from another PC where the sound works correctly
    - Setting devmgr_show_nonpresent_devices=1 and to see if there were any suspicious instances of drivers shown in Device Manager

    I am now running out of ideas and would greatly appreciate any help! I am ready to run any diagnostic tools suggested and to post results in this thread as suggested by anyone. Many thanks in advance!

  2. musksnipe

    musksnipe Guest

    Check that Windows Audio Service is started.
    Go to Control Panel>Administrative Tools>Services
    Scroll down the list of services until you find the Windows Audio service.
    Right click on it and choose Properties.
    Make sure it is set to Automatic and Start is checked

    Go to Start>Control Panel>Sounds and Audio Devices.
    On the Volume tab, make sure that the "Place volume icon in the taskbar" is checked.
    (This may be greyed out without the driver installed properly. Come back to here after installing your audio, to be sure it is set properly)

    Download your chipset and install it:

    Download and install your audio driver:

    Did that work?
  3. erodrigue

    erodrigue Private E-2

    Hi musksnipe,

    Thanks for the quick reply!

    I tried all that you have suggested:

    Windows Audio Service is automatic and started
    Volume controls are grayed out
    I installed the chipset
    I installed the audio driver

    In fact I had installed the chipset and audio driver before my original post, but I forgot to include it in my initial list. Anyway I tried both once again but it did not solve my problem.

    Would you have any further steps to suggest?

    Thank you,
  4. musksnipe

    musksnipe Guest

    Hi Eric.
    We begin at the beginning.
    Check your Device Manager.
    Are there any devices listed under Other Devices?
    Are there any Unknown devices?
    Is the MS UAA Bus driver listed in System Devices?

    Use Everest to get a report of your system’s hardware, OS, and drivers. Upload the report as an attachment
    Everest: http://www.majorgeeks.com/download.php?det=4181
    When Everest is done scanning, click "Report" at the top of the Everest window, click next to get to "Report Profile", select "Hardware related pages", click next, select "Plain Text", click "Finish". Then when it is done processing, click "Save To File". Save it where you want to. (I would use Desktop.)
    Click "Go Advanced" in the MG reply box, scroll down a little way until you see "Manage Attachments", click it, browse to your file, click "Upload", and close the window. Then submit the post. You may have to also type something in the reply box, like, "Here's my report.", so that it will submit.
  5. erodrigue

    erodrigue Private E-2

    Hi musksnipe,
    Please find my answers below.
    No. There used to be a few but I deleted them days ago (before posting to that forum).
    Yes it is

    Everest Home will not start because I am member of a domain. It says to use Everest Corporate instead. Is there any way to have Everest work on my computer (maybe if I login as local Admin rather than as domain user?). Or is there any other software I could use to generate a similar report?

    Many thanks,
  6. musksnipe

    musksnipe Guest

    Is it installed without problems? (no ? or !)

    Try this:

    I'm not familiar with how to get a report out of it, but it shouldn't be hard.
  7. erodrigue

    erodrigue Private E-2

    Hi musksnipe,

    Yes, the MS UAA Bus driver is installed without problem (no ? or ! besides it).

    Here is my Belarc report. Belarc display results in html format with references to image files n the local hard drive. I sent the .html file as well as a PDF printout generated with Firefox/PDFCreator. I hope it is not too painful to read. The easiest would probably be to install Belarc on your computer and then open the .html file.


    Attached Files:

  8. erodrigue

    erodrigue Private E-2

    One more thing, I used to be up to date with MS security patches, but I suspect I lost most of them when doing the Windows Repair. This is why Belarc reports a lot of missing patches.

  9. musksnipe

    musksnipe Guest

    Wow, Belarc puts out a lot of info!
    I don't think this is part of the problem, but make sure to get your Windows updates caught up.

    I'm not seeing anything right off that may be causing this.
    The exclamation points in Device Manager means the driver is installed but with some kind of conflict.

    I do see that you have Skype installed. Sometimes, apps like that will mess with your audio.

    At the moment, I have two things to try.
    Uninstall the Microsoft Kernel System Audio Device, then do a complete shutdown and then reboot. It's possible that's where the conflict is, but I doubt it. The MS Device should reinstall on reboot.

    If that doesn't work, uninstall Skype.
    Check for any left over Skype folders in Progran files, Common Files, and in the App Data/Local/Roaming folders in User files.
    Delete them all.
    Then run CCleaner's Registry tool, then shut down, reboot, and check your sound again.
    At this point you may want to try another reinstall of your audio driver.

    Oh, one other thing, you may want to redownload the audio driver, get off line, stop your AV, and then reinstall the driver.

    Let me know if that fixed it.
    I'll try to do a little research into Sigmatel.
    It's been a while and I've been dealing with Realtek mainly lately, but if I remember right, Sigmatel and Realtek are very similar in their problems.
  10. erodrigue

    erodrigue Private E-2

    Hi musksnipe,

    Please find my comments below.

    Done, did not fix the problem. By the way the MS Kernel System Audio Device also shows up with a yellow exclamation mark. I removed it and upon reboot it came back with the exclamation mark again.

    Done, did not fix the problem. Skype is gone, CCleaner reported lots if issues which I allowed it to fix, but the sound did not come back.

    Done, did not fix the problem. The driver comes back with the exclamation mark again.

    Done, did not fix the problem. The driver comes back with the exclamation mark again. Afterwards when browsing in the downloaded files for the driver, I ran into file kb835221.exe which gave me some hope, I uninstalled my driver, installed the kb835221.exe and it seemed to do a reinstall of the driver among other things, but then the same exclamation mark came up on the driver. Note that when reinstalling the driver, I sometimes get a tray popup saying there is a problem with the new driver, maybe related to some hardware problem.

    I don't remember if I already told you that we also ran the Dell HW diagnostic tool and the sound test passed, I did hear the test sounds.

    I am really out of ideas now and any suggestion will be most welcome.

    Thank you very much,
  11. rogvalcox

    rogvalcox MajorGeek

    Don't mean to interrupt musksnipe...but I just had an audio problem of my audio disappearing after installing Skype in conjunction of my Logitech Webcam.

    I just want to ask...seing that you had Skype...do you have a Logitech camera installed...if so there is an issue of neither Logitech nor Skype wanting to claim who's issue this is, but...Communcation_Helper.exe seems to cause this issue.

    The Logitech Quickcam Software Application is not required to use the camera with Skype, so if your not using that Quickcam software, then I would uninstall it and that should resolve the Communication_Helper.exe issue, and in turn hopefully resolving your audio issue.

    If this isn't your case, then ignore my interruptions and carry on!! :):cool
  12. erodrigue

    erodrigue Private E-2

    Hi rogvalcox and musksnipe,

    This morning I tried lots of things, uninstalls, reinstalls, driver updates... I even updated my BIOS because for some reason my laptop's BIOS doesn't allow to disable the onboard sound card, anyway... After a while I figured I would enable the Windows XP boot logging to see if it reported anything suspicious. The ntbtlog.txt file contained this line many times:

    "Did not load driver \SystemRoot\system32\drivers\lvusbsta.sys"

    After verification, lvusbsta.sys is related to the Logitech QuickCam, so I decided to uninstall all the Logitech QuickCam software. After the uninstall it asked to reboot the PC but I said No (I was doing other stuff). A few minutes after, I saw rogvalcox's post and I realized I could be only 1 reboot away from resolution, so I rebooted and voilà, here's my sound back!

    I cannot confirm if the problem is a conflict between Skype and QuickCam because I already had uninstalled Skype a few days ago as adivsed by musksnipe but it did not fix the problem. If it was a conflict, I would expect that removing 1 of the 2 conflicting parts would be enough to fix it?

    Also, what seems very odd to me is that I had Skype installed on this laptop for over 1 year and QuickCam for a few months, and everything worked fine. It stopped working all of a sudden, after nothing had apparently changed. Maybe some automatic update of Skype or QuickCam happened behind my back?

    Anyway, this issue is now :):):) FIXED :):):). Thank you very very much to you musksnipe, and you rogvalcox for taking some time to help me out. And thanks to majorgeeks for existing!

  13. musksnipe

    musksnipe Guest

    I don't really understand how those conflicts come about, between anything that uses audio, Skype, webcams, etc. but they do sometimes. (Bad scriptwriters)
    Glad you got the problem fixed.

    @ rogvacox.... always bump in if you have info that is being missed. I totally missed the webcam.
    Thanks for reminding me that those are problems, at times, too.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds