1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No Sound on Toshiba Laptop

Discussion in 'Software' started by GeoffB, Apr 26, 2012.

  1. GeoffB

    GeoffB Private E-2

    Hi everyone, A newby here.

    I lost the sound on my Toshiba L350 laptop just after I installed an audio analyser program which I beleive tried to instal a soundblaster drive, but I'm not sure!

    However, I've tried deleting, updating and unstalling the Realtek HD audio driver with no success. I've also downloaded the lated drive from the Realtek site (ver.2.68, dated 12/4/2012).
    Each time open the driver and run the test, I can see the bar graph change with the test signal but still no sound.

    I also ran Microsoft Fixit which says there are no issues with the sound and even re-installed windows vista using the 'clean windows option - still :-on change.
    Any help would be most welcome

  2. tgell

    tgell Major Geek Extraordinaire

    From what I have read, the Toshiba L350 has a mute button. Make sure that it has not been enabled by accident. There may also be some kind of mechanical switch to increase the sound. Can you hear sounds through earphones?
  3. GeoffB

    GeoffB Private E-2

    Hi Tgell,
    Many thanks for the quick responce. You are correct there is a speaker on/off switch just above the keyboard and, a "function esc key" that puts a speaker on/off sigh next on the bottom right of the screen. However activating either of these still fails to give give me sound. I can also confirm no sound when headphones pluged in.

    The fault does indeed look a though it could have been the above problem as everything looks fine. All the tests I've done thus far suggest the sound card is working .

  4. tgell

    tgell Major Geek Extraordinaire

    Are there any errors shown when you run dxdiag? Are there any yellow exclamation marks in Device Manager? Is more than one sound device shown in Device Manager? Can you provide the last four digits after L350 on your computer? Is it a Satellite or Equim L350?

    The following isn't exactly related to your problem, but make sure that digital is not selected.

    Last edited: Apr 27, 2012
  5. GeoffB

    GeoffB Private E-2


    I've run dxdiag as suggested and no problems are reported. Also no yellow triangles on any hardware.

    The computer is shown as a Satilite L350-159. Model No.PSLD0E-03Q0 1 MEN

    Your last comment regarding the digital output is interesting as I've been doing some research in tinternet which has led me to the following:
    When I open the playback device window and double click on the speaker Icon, to bring up speaker properties, it shows both the APAPI internal Jack and front panel 3.5mm jack under jack information. However, the LR (left/Right I assume) is next to the APAPI black dot, which suggest to me that the sound is being routed to the digital output and not the front panel jack and Speakers.

    However, I cant find any way of changing which output is selected. I tried following the video on the website you kindly attached but my version of Vista does not show a Realtek menu when I go through Hardware and Sound from the control panel .

    Your further comments would be appreciated.

  6. tgell

    tgell Major Geek Extraordinaire

    If you right click on the speaker icon and select playback devices, is Realtek HD shown there? Realtek HD manager should be in the system tray. Is there a Realtek HD manager icon when you set the Vista Control Panel to classic view in the left pane?
  7. GeoffB

    GeoffB Private E-2

    Hi Tgell,

    Many thanks for your efforts thus far, I know it can't be easy without the computer in front of you.

    When I right click the speaker Icon and select playback device, the playback sub-window opens showing a speaker Icon with a green tick next to it and says " speakers Realtek high definition audio working". There is also a bargraph to the right. If I left click on the speaker Icon and run test, you can see the bar graph rising indicating sound. But nothing from the speakers.

    Since I've installed an updated driver, I can now see the Realtek HD manager. However, trying all the facilities, there's still no audio.
    Also if I play a track from windows media player and open the volume mixer, you can again see the display changing with the sound.

    To date I've tried the following drivers, all with the same results:
    version Date
    6.0.6000 21/6/2006 30/1/2008 27/3/6602
    2.68 12/4/2012

  8. tgell

    tgell Major Geek Extraordinaire

    If you right click your speaker icon and select Open Volume Mixer, make sure all of the setting are at max. and the speaker icons do not have a red circle next to them.

    I really do not understand what is going on other than it may be a hardware issue, especially since you reinstalled Vista.

    Is this Vista 32 bit. If so, download the Value added package. This may have some additional setting for sound. You may already have it installed if you reinstalled from the recovery partition of the hard drive. It provides support for the different function buttons. This is for 32bit only.

  9. GeoffB

    GeoffB Private E-2

    Hi Tgell,

    When I open volume mixer I can see the speaker Icon and slider. the slider moves with the manual volume control. There are no red circles to show mute or audio switched off. Indeed when I hover over the speaker Icon( next to clock bottom right) the baloon reads "Volume 88 and Realtek High definition audio".
    I re-installed the Toshiba value added package as suggested and it seems pretty basic. When it tests the sound device all it askes if I can hear sound from either speaker. When I click no it just shows FAIL against that test but does not provide and further information as to the possible cause.
    Even Microsoft's Fixit tells me that everthing is working OK

    It look just like someone has unplugged the speaker ! If I turn the speakers off via a key-press I can be clearly seen a red circle next to the speaker icon and I can turn this on and off at will with any of these controls.


  10. tgell

    tgell Major Geek Extraordinaire

    Right click the speaker select playback devices. Right click in the blank area of the window and select show disabled devices. Does anything pop up?

    Now that you have the value added packaged installed. See if the pressing the mute button on and off has any effect.

    I am truly starting to run out of ideas on this.
  11. GeoffB

    GeoffB Private E-2

    Hi Tgell,

    There are no other drivers shown when I tick "enable disabled drivers"

    Also now I've downloded Toshiba's ADP the following happens:

    1 when I press the FN (function) all the "f" keys ICONS are visable across the top of the screen.
    2 Now if I hold down the FN key and press the ESC key I can toggle a spreaker mute ICON on the top of the screen on/off (ICON changes to shown speaker mute). However the speaker ICON (bottom right) no longer shows on/off. The only way I can get this to toggle on/off is to disable the driver whilst in driver properties.
    3 I've also noticed that the speaker on/off button just above the keyboard seems to no longer have any effect.

    I don't know what this tells you but the whole thing is driving me mad!

    I'm just greatfull for your help.

  12. tgell

    tgell Major Geek Extraordinaire

    I am really at a loss as to why this is happening. If you have all of your data backed up, you can try to do another factory reset using the recovery partition on the hard drive. This should take it back to the state it came from the factory. Any programs or data added will be lost.

    Another option to see if this is indeed a hardware or software error is to download Puppy Linux. Burn the iso with Imgburn. Boot the CD and when you get to the Puppy desktop, play a song you have on your computer. When you get to the desktop, a hard drive will show at the bottom left. Click it and you will open the file manager. Browse to the location on your computer with a MP3 and click. Edit: you can also click the play icon on the desktop and browse you an MP3.

    Edit: Here is a link showing the file manager in Puppy. Scroll down to "Mounting drives and partitions in Puppy"


    How to write an image file to a disc using ImgBurn
    Last edited: Apr 30, 2012
  13. GeoffB

    GeoffB Private E-2

    Hi Tgell,

    I ran Puppy Linux and tried to play a MP3 file but still no sound. I think you are therefore going to tell that I have a sound heardware fault !!! Is this correct?

    I also tried the recovery you suggested but because I've no sound I can't hear "the beep" so I don't know how long to hold down the zero key. I tried holding the zero down for approx. 60 sec, the after release windows started to load. Should I be able to see any other visual indication to shown when I need to release the key? Unless your going to tell me not to bother because of a hardware issue!

    As an aside, the Puppy Linux tooks like a very good little program.Geoff
  14. tgell

    tgell Major Geek Extraordinaire

    If Puppy could not play the sound, then I would say it is a hardware fault.

    60 seconds is too long. You may not have the recovery partition on the computer. Go to Disk management and look for a recovery partition. It should be around 10GB. Try tapping the zero key instead of holding it down as the laptop powers on.

    Here is the procedure as outlined by Toshiba.


    And another:


    Yes, Puppy is very good, especially when you have to recover files if Windows does not boot.
  15. tgell

    tgell Major Geek Extraordinaire

    I am pretty sure this is not the problem because you see the bar graph when playing audio, but make sure onboard audio is enabled in BIOS.
  16. GeoffB

    GeoffB Private E-2

    Hi Tgell,

    That sounds like some good news!

    I've tried looking for something relating sound in my bios setting but don't realy know where to look. Some advice would be helpfull.
    I've also noticed that since re-booting, my Realtek driver has reverted back to the old driver dates 21/6/2006 ver. 6.0.6000. If I re-run the latest driver installation program again I can reload this latest 2012. Do you think I have a driver conflicked, and how can I delete unwanted drivers. Because since I started this ( which seems like years! ), I must have tried several driver versions?

  17. GeoffB

    GeoffB Private E-2

    HI Tgell,

    Further to the below thread. Whilst looking a bios issues I ran a "memory test" and whilst the test was running there was a status message saying the computer has a hardware fault. Also after the test and an auto re-boot the computer said there was also a memory fault. However, when I run dxdiag it shows 2038meg of RAM or is it talking about hard drive memory?

  18. tgell

    tgell Major Geek Extraordinaire

    I am not sure where the setting in BIOS would be. It may not have that option available. Just go through all of the options and see if something like audio or sound is available.

    Delete your sound drivers in ADD/Remove Programs if shown. Then download DriverSweeper. You need .Net 3.0. Run it in safe mode in an admin account and select the Realtek audio drivers if any show up. Then reinstall the v2.68 drivers.



    Edit: Yes, that would be your RAM memory it is talking about. You could also test with Memtest+ and let it run 7 complete passes. But, not sure why that would cause a sound issue. Burning the iso will create a boot cd. Let it


    Last edited: May 1, 2012
  19. GeoffB

    GeoffB Private E-2

    Hi Tgell,

    Not been on the computer for a few day as I got fet up with the whole thing!

    Anyway, had another look in the BIOS settings and these is nothing relating to sound at all.

    Also ran driver sweep in safe made and it came up with the following:
    ASUS sound
    Creative Sound, and
    Realtek sound

    I ticked all three, cleaned, re-booted and ran the 2.68 Realtek software, confirmed Windows was showing it as the sound driver but still no sound.

    However, after switching off and on again onvernight I was amaised to see that Windows had re-loaded the old Microsoft 2006 sound driver I thought driver sweep had deleted.

    I also asked driver manager to show old drivers but it didn't show any other drivers apart from the old Microsoft 2006 driver.

    Repeating a driver sweep again showed the above 3 drivers I thought had been deleted.

    Does it look like I still have a driver conflict issue?

  20. tgell

    tgell Major Geek Extraordinaire

    I am not sure why they came back after deleting with DriverSweeper unless Windows still had the drivers available. What I do not understand is why Driver Sweeper saw the Creative along with the Asus drivers, since you have a Toshiba laptop. Maybe it just gave you the option to delete those if needed or the Realtek Driver package added those drivers.

    You could try to go through the same procedure, remove Realtek through ADD/Remove programs. Uninstall the sound drivers with Driver Sweeper. Then do not install the Realtek Drivers. Let Windows Update try and find the driver.

    I have a feeling this is a hardware issue as Puppy did not detect your sound card and you do see the graph when sound is trying to play but no sound is coming from the computer or through the earphone jack. You could try another Linux distro like Ubuntu but that is a large download and I do not know if you have a bandwidth limit or not. If that does not detect your sound card, I would go with the hardware problem and then look to a USB solution using earphones like this or go to a shop and see if they can find the problem.

  21. GeoffB

    GeoffB Private E-2

    HI Tgell,

    Many thanks for all the great advice you have given me over the past weeks, however, I've taken your advice and purchased a USB sound card from Ebay ( £1.00 plus postage). It arrived today and works fine which means that I can now speak to my family on Skype again.

    Once again I'm very greatfull for your time and many thanks to the people who put this type of forum together.

    Best regards

  22. tgell

    tgell Major Geek Extraordinaire

    Sorry you could not get the sound working on the laptop but you were able to find another solution that was not expensive. I guess those cheap USB sound cards on EBay do work. I was going to link to one of those but did not know how it would work for you. Thanks for the feedback.
  23. choganj

    choganj Private E-2

    It might be a hardware problem as well as software. First of all please make sure your hardware is in working condition (also make sure you have sound card installed to begin with).

    If you re installed your operation system recently, chances are you didn't installed proper sound card drivers, so please make sure you installed proper sound card drivers.

    If still you can't rectify this issue, you can use a USB sound card.

    You can also view http://www.techyv.com/questions/no-sound-coming-out-my-laptop for more information.

    I hope it would be of some help.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds