1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

nv4_disp stuck in an infinite loop

Discussion in 'Software' started by Tomo Tomo, Jun 10, 2006.

Thread Status:
Not open for further replies.
  1. Tomo Tomo

    Tomo Tomo Private E-2

    Basically i have no real understanding of what’s happened or how to fix it.
    Every time i start my computer up i get a blue screen saying:

    A problem has been detected and windows has been shut down to prevent damage to your computer.

    The problem seems to be caused by the following file: nv4_disp

    If this is the first time you’ve seen this stop error screen, restart your computer. If this screen appears again follow these steps:

    The device driver got stuck in an infinite loop. This usually indicates a problem with the device itself or with the device driver programming the hardware incorrectly.

    Please check with your hardware devices vendor for any driver updates.

    Technical information:

    *** STOP: 0X000000 EA (0X8712F260, 0X87134128, 0XF7CA90CBC, 0X00000001)

    Begging dump of physical memory
    Physical memory dump complete.
    Contact your system administrator or technical support group for further assistance.

    If i then restart my computer i get to choose to:
    -Restart windows normally
    -Configure to last appropriate setting (or something along those lines)
    and the usual
    -Start in safe mode

    For a few days i could just select "Restart windows normally" but then that just started to take me back to the blue screen so i tried "Configure to last appropriate setting" which worked once
    and now im stuck with having to start it up in safe mode so i can ask for some of this communities time :)

    Any help would be greatly received
  2. Tubnotub1

    Tubnotub1 Private First Class

    I belive nv4_disp are your nividia display drivers, you may want to see if going into safe mode, and DELETING your nvidia drivers (only your display drivers) fixes the problem.

    start --> control panel --> add or remove programs --> nvidia drivers --> DISPLAY DRIVERS ONLY.

    Once they are uninstalled try to start windows normally. Windows will load up and use the windows display drivers, as opposed to the nvidia drivers, which seem to be corrupted in your case.

    Once you are back in windows, head on over to nvidia and re-install their drivers (I would suggest the most recent WHQL driver, NOT a beta driver). The most current driver for XP can be found here.


    Good luck, post back if you need anymore help!
  3. Jerkyking

    Jerkyking Sergeant Major

    Try downloading this and following the instructions. Download the new drivers first. Its worked for me.
  4. Tomo Tomo

    Tomo Tomo Private E-2

    wow thanks for being so quick about it you both really helped
    my computer is now running normally :D
    Last edited: Jun 10, 2006
  5. Tomo Tomo

    Tomo Tomo Private E-2

    Im sorry to say its happened again after working once.
    I deleted the nvidia display drivers as you said and replaced them with the WHQL which seemed to work but then when i turned it on this morning i got the blue screen saying exactly the same thing.
  6. Tubnotub1

    Tubnotub1 Private First Class

    Well that wont do. Are all your the settings on your computer at stock, are you overclocking anything? Also, go ahead and list your specs for us, so that we can help you better. Sorry to hear the problem has resurfaced. Most importantly, what video card are you using?
  7. Jerkyking

    Jerkyking Sergeant Major

    Your video card my be going. If you have access to another to try for awhile, see how it goes.
  8. Tomo Tomo

    Tomo Tomo Private E-2

    Thanks again you two sorry this reply has taken so long but i went away for a few days
    my computer seems to be absolutely fine now :) cheers for all the help
  9. werLd

    werLd Private E-2

    FIXED Finally!!! I have had this issue for a long time and tried many things. In Linux I noticed it was crashing with 3d games too which made me look at the BIOS. This may be a issue with AMD64 and video card.

    Other people suggested video card was going bad, bad power supply, not true!!

    PNY 7600 GS 512
    AMD 64 2600
    MB - ASUS K8N

    Fix for me was:


    1.) Turn off APIC stuff in the BIOS
    2.) Must reinstall windows after this (Didn't work without reinstalling)


    1.) No reinstallation, only pass 'noapic' option to the kernel when booting.

    Let me know if this works, it was very frustrating for me to find but now has been running for 2 weeks straight in my 3d game with no crashes.
  10. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member

    Cheers for your fix info but as this thread is near 2yrs old, and the original poster had fixed their issue with infinate loop, the thread is now closed.

Thread Status:
Not open for further replies.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds