1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

One of the USB devices attached to this computer has malfunctioned...

Discussion in 'Software' started by Kestrel13!, Sep 28, 2012.

  1. Kestrel13!

    Kestrel13! Super Malware Fighter - Major Dilemma Staff Member

    ... and windows does not recognize it.

    I have been getting this error for about a week now. ALL I use USB wise is a little tiny mouse reciever for wireless mouse and a flashdrive.

    I have opened up Device Manager > and uninstalled the "Unknown" device and even tried Disabling it, thinking, well if it's broken, might as well. But when I do it tells me it needs enabling, and then it nags me again about the malfunctioning device.

    Weird thing is, after I uninstall the unknown device, or disable it, my mouse reciever and flashdrive still function... surely meaning they are NOT malfunctioning....so what the hell IS ?? :confused I even went out and bought a brand new 8gig flashdrive yesterday when I was in town because old one was 5 years old. Today, I got the error message again about this malfunctioning device... unknown device, and if I open up dev manager, it's listed...unknown.

    Help folks, I hate this sorta stuff LOL

    (Thankyou :))

    Attached Files:

  2. Caliban

    Caliban I don't need no steenkin' title!

    Hi, Kes...

    First thing that comes to mind is to check the USB Suspend functions in Power Management - but that doesn't make sense if the symptoms just magically appeared...

    You've already taken the first steps I would have tried...
  3. Caliban

    Caliban I don't need no steenkin' title!

    Off-the-wall: check Device Manager again, look in the Disk drives and Human Interface Devices sections, see if anything's screwy there. What I'm looking for is the possibility of a card reader (SD, SM, etc.) malfunction which can exhibit as a USB problem.
  4. Kestrel13!

    Kestrel13! Super Malware Fighter - Major Dilemma Staff Member

    No unknown devices in those sections, no exclamation marks or nothing. :confused Why does all the weird stuff happen to me??? .......:-D
  5. cipher

    cipher Major Geek Extraordinaire

    How about looking in Computer management > Disk management and see if there is an unknown or not plugged in device mapped to a drive letter there. Seems I had this issue once, and changed the drive letter mapped and the issue went away...
  6. Kestrel13!

    Kestrel13! Super Malware Fighter - Major Dilemma Staff Member

    Nothing unusual there cipher...

    Attached Files:

  7. sach2

    sach2 Major Geek Extraordinaire

    I italicized my original response to save for later. I saw several threads that recommended unplugging the computer for a minute or two and then restarting to clear the error. (Some also recommended pulling the CMOS battery but I don't think that is necessary.) I'd give that a quick try. That port seems to be an internal USB "device", it shows on mine in USBdeview as unknown as well but I don't get the error 43.

    Maybe run USBDeView and see what it lists. It shows a list of all recent USB activity even if the device is no longer connected.

    If you have only the USB mouse currently attached then you can just delete all of the other entries it shows. When you reinsert a device it will generate a new entry so deleting the old ones doesn't hurt. That would give you a fresh start as to old entries causing problems.

    If you still get the errors then it may have something to do with the USB controllers but I don't know enough about them to offer much help.
  8. cipher

    cipher Major Geek Extraordinaire


    Try mapping the kingston USB device to another drive letter, eject it it, reboot.
  9. Kestrel13!

    Kestrel13! Super Malware Fighter - Major Dilemma Staff Member

    Hi sachs. You mean just the items in my screenshot listed as USB Root Hub? I'm a bit slow on the uptake here, ever so sorry. I see other items like USB composite device, USB mass storage device...should I delete those too as well as the "unknown" that shows? :confused (Thanks for bearing with me everyone)

    ... I ran that tool and put the results into a text file which seems legible to me. Here ya go.

    Attached Files:

  10. sach2

    sach2 Major Geek Extraordinaire

    Hmm, looking at that file you don't have anything listed for USB Port0002 Hub0001 which was the original error. Perhaps that is because Windows "Stopped this Device". It doesn't really matter if you delete any or all of those items. You can just skip deleting them since none relate to that particular error.

    I'm not really sure what to try next. I think I would shut down and unplug for a minute or two(simple thing to try) If a laptop you would have to remove the main battery and unplug. Then restart go to Device Manager and look under the Universal Serial Device Controllers and see if you still have the unknown device. If not right-click each of the USB Composite Devices listed and see if any of them are Port0002_Hub0001 and if they are listed as now working correctly.

    Attached Files:

    Last edited: Sep 28, 2012
  11. the mekanic

    the mekanic Major Mekanical Geek

    Looks like a startup issue in the registry.

    If it's W7, maybe a Startup Repair would do the trick...
  12. Kestrel13!

    Kestrel13! Super Malware Fighter - Major Dilemma Staff Member

    I have not fully finished following what sachs said yet however I would like to point out, could be seperate issue entirely, but each time I move laptop lid (close/open) it makes that USB noise... ya know what I mean, like when you take a stick out without safely removing...)
  13. sach2

    sach2 Major Geek Extraordinaire

    Hi Kestrel,

    Since it is a laptop give the model number so we can take a look to see if it is a common problem with that particular model.

    From what I saw earlier I'm guessing this is Win7 64bit?
  14. cipher

    cipher Major Geek Extraordinaire

    another street you can walk down:
    Your power settigs are to your liking I presume? What about sleep mode on lid close?
  15. Caliban

    Caliban I don't need no steenkin' title!

    Whoa! That can't be good - sounds more like a cable and/or wire getting squeezed / mashed, which could very well be fooling something into thinking there's a USB problem. Just think of all of the times we've had strange USB-related symptoms in desktops when a loose USB connector cable hits the case, etc...
  16. plodr

    plodr Major Geek Super Extraordinaire

    Closing the lid puts the laptop to sleep or hibernate which is probably shutting off the USB ports.

    Have you checked what the power settings are for USB? I'd suggest never to avoid problems.
  17. Caliban

    Caliban I don't need no steenkin' title!

    Already asked about the USB suspend functions way back in post #2, and none of the laptops here (we've got 5) are configured to do anything power-wise when the lid is closed...

    If the lid closing/opening is indeed changing the USB state on purpose, that's one thing, but if this is an anomaly then it should be checked out...
  18. plodr

    plodr Major Geek Super Extraordinaire

    My Win 7 netbook hibernates when I close the lid but my USB ports do not ding as if the power is going out. But computers are strange and maybe something changed Kestrel's USB ports power settings. You mentioned it but she never responded to post #2. She did answer post #3. I just thought it might be something that was overlooked.
  19. cipher

    cipher Major Geek Extraordinaire

    I saw no reply to that either, it is why I mentioned it as well. I saw a few reports of that exact sound issue out there, but no resolution. Worth investigation. Like the drive mapping... (In my case the drive mapping didn't show, but remapping all the letters that had been used somehow freed something up and my problem disappeared)
  20. Caliban

    Caliban I don't need no steenkin' title!

    You're both right, and I apologize - my bad. Kes, what about those power settings?
  21. satrow

    satrow Major Geek Extraordinaire

    Most likely the webcam, if there's one fitted, they're internally connected to USB and cabled via the screen hinge somewhere.
  22. Kestrel13!

    Kestrel13! Super Malware Fighter - Major Dilemma Staff Member

    Sorry, sorry. You have all been so kind and helpful and I have not been around. Just busy as a bee I'm afraid. OK here goes.

    Not sure how to do this Caliban. *cringes*
    I have yet to try this. I will do so as soon as I get chance and report back. Can't see it being tonight!

    Will try these too and let you know.
    It is a Toshiba Satellite A300 1JR Win 7, 32 bit.

    I have told my laptop to "do nothing" when close lid, but it still makes that noise I described.

    Mine are on enabled as you can see from my screenshot. Should I disable?

    Webcam on this laptop has NEVER functioned at all. Right POS, a chicony I believe. No software for it remains on this laptop.
  23. Caliban

    Caliban I don't need no steenkin' title!

    You have nothing for which to apologize, Kes...;)

    To check your USB suspend options:

    1. Navigate to Control Panel > Power Options.

    2. For the 'Active' Power Plan (the plan you are presently running), select Change plan settings > Change advanced power settings.

    3. Expand the USB settings, and toggle the USB selective suspend options.

    4. OK out / save any changes.

    See if any of your symptoms change - if not, you may go back in and reverse the changes.
  24. Kestrel13!

    Kestrel13! Super Malware Fighter - Major Dilemma Staff Member

    Duh, I did this earlier and forgot to attach the damn screenshot.

    My choices are enabled or disabled. Should I disable?

    Thanks guys and gals! :)

    Attached Files:

  25. Caliban

    Caliban I don't need no steenkin' title!

    Yes ma'am - all we're looking for here is if the symptoms change.
  26. satrow

    satrow Major Geek Extraordinaire

    You might need to fiddle with DevMan's View settings (Devices by connection) and drill down the (+)'s to disable the USB hub upstream of the malfunctioning device, otherwise when Windows runs a check on the connected devices (as in connecting a flash drive to the 'twin' port). This will mean that you 'lose' the free USB port.

    The alt. is to 'pop' open the lid and disconnect the webcam - if it ain't connected ...

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds