1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ping command does not work

Discussion in 'Hardware' started by fire-medic8104, Feb 21, 2007.

  1. fire-medic8104

    fire-medic8104 Private E-2

    I can't connect to the internet so I called customer assistance and they told me to go to the ping command.

    When I ping google.com, I get a response "C:\WINDOWS\system32\ping.com is not a valid Win32 application"

    I have never seen such a thing. I am running Windows XP.

    Anyone ever seen such a thing? This just all started one day when I restarted the computer. I can run the ipconfig command and get everything back.

    I talked to the technical assistance and he said my modem is logged on and recieving traffic, but without the ping command, that was the most he could tell me.
  2. fire-medic8104

    fire-medic8104 Private E-2

    I also noticed that I don't have a system32 folders in the windows directory. Could that be part of the problem? If so how do I fix it?

    I would do a complete restore/recovery of my computer but I didn't get a recovery CD when I bought it.
  3. fire-medic8104

    fire-medic8104 Private E-2

    I fixed the ping problem, kinda. If I do "ping.exe google.com" I get a result.

    Though it is request timed out with no responses. Now I have to fix that problem.
  4. Mada_Milty

    Mada_Milty MajorGeek

    You've got far worse problems, I'm afraid.

    ping.com is NOT a native Windows program! ping.exe is, but ping.com is almost surely malware-related!

    Suggest you follow the instructions in this post to ensure your system is clean!
  5. cat5e

    cat5e MajorGeek

    Ping.exe is a Network command line program that lets you check basic connection over the Network.

    Click Start / Run

    Type into the Run box: cmd and press enter.

    Type at the DOS prompt ping208.101.7.150

    If your basic connection is OK you would see this.

    Pinging with 32 bytes of data:

    Reply from bytes=32 time=54ms TTL=47
    Reply from bytes=32 time=52ms TTL=47
    Reply from bytes=32 time=52ms TTL=47
    Reply from bytes=32 time=52ms TTL=47

    Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 52ms, Maximum = 54ms, Average = 52ms

    What this means?

    I pinged MajorGeeks server.

    The connection is Good, No loses, and Fast 52ms.
  6. fire-medic8104

    fire-medic8104 Private E-2

    I can't do cmd from run, I have to type command to get it.

    Sounds like malware. I guess in a way that is good. This way I can hope my computer itself is still good, if I can get rid of it.

    Thanks for the info.
  7. fire-medic8104

    fire-medic8104 Private E-2

    Ok, here's where I am at so far.

    Ran the tutorial on malware, found a few problems, but that didn't fix it.

    I fixed the ping by reading another post about finding ping.com and deleting it. Did that and my modem will work with my laptop, but not my desktop. I can ping my ip address, but the modem address of times out.
  8. Colemanguy

    Colemanguy MajorGeek

    Then your modem may not be pingable,
  9. fire-medic8104

    fire-medic8104 Private E-2

    Then I need to figure out why I can't connect. But I would think the modem is pingable, since technical support was having me do it.
  10. Adrynalyne

    Adrynalyne Guest

    You are pinging the internal side.

    The ISP is hitting the public end.

    Not even relevant.

    Try pining it from SafeMode w/ Networking.
  11. cat5e

    cat5e MajorGeek

  12. fire-medic8104

    fire-medic8104 Private E-2

    I can ping in safe mode and get a reply. I can also run the cmd command from the command line.

    What does that mean?

    And I can connect to the internet
    Last edited: Feb 22, 2007
  13. Adrynalyne

    Adrynalyne Guest

    If something is blocking the ping, it indicates a program is intervening. To ignore it, is silly.
  14. Adrynalyne

    Adrynalyne Guest

    That an application is blocking your access. Got a firewall? Turn it off, and see if thats the issue. If it is, follow this article to narrow it down.

  15. fire-medic8104

    fire-medic8104 Private E-2

    It is not a firewall. I have deleted all of them, and windows firewall is disabled.
  16. Adrynalyne

    Adrynalyne Guest

    Then, have at it with the article. Something is intervening, that doesn't run in Safe Mode.
  17. fire-medic8104

    fire-medic8104 Private E-2

    Ok, that fixed it so how do I tell what application is blocking?
  18. Adrynalyne

    Adrynalyne Guest

    Well, its a dvide and conquer sort of thing. You start re-enabling things, little by little, until it breaks again. Then, you narrow down from the last bunch you enabled, which one did it.

    Then post back here.
  19. fire-medic8104

    fire-medic8104 Private E-2

    I thought I did that. When I did the system and process, like the article said neither caused it to have a problem. Do I start restarting things in the startup menu? I just want to make sure that is what you are talking about.
  20. fire-medic8104

    fire-medic8104 Private E-2

    Forgot to add that I appreciate the help from everyone. As usual, you guys came through.
  21. Adrynalyne

    Adrynalyne Guest

    Yes, start re-enabling that which you disabled.
  22. cat5e

    cat5e MajorGeek

    I every thing works Ok and there is normal connection, you are right.

    But when a Network system does not work well the ping is working, or Not, is just part of the syndrome not the problem.

    So first one should Fix the Network, then if the ping by it self does not work it is another story.
  23. Adrynalyne

    Adrynalyne Guest

    Thats not to say to ignore ping. A ping timing out to a local IP such as modem is usually not a network issue. K.I.S.S. applies here before getting your hands too dirty.

    Error like: Destination Host Unreachable are different.

    Agree? Of course you do. I knew we could work this out. :)
  24. fire-medic8104

    fire-medic8104 Private E-2

    I was able to narrow it down to the Sygate firewall. I didn't even have it running but it was blocking all internet access. I didn't even have it on and didn't see it in the processes of the task manager.

    Uninstalled it problem solved and set msconfig back to normal startup.

    The only problem is during all this, I must have screwed up something, because my sound on my computer is now screwed up. It seems like the equalizer is messed up. I know that is not an accurate description, but I don't know how else to explain it.

    I was watching a comedy show on dvd (that I have watched on this computer before so I know it works fine), but the audience laughing sounded fine, but the comedian sounded like he was talking in a can or real distance.

    I'm not sure what I did. I did notice after all this changing, that Windows media player upgraded. I don't know if that had anything to do with it or not. Any ideas?
  25. Adrynalyne

    Adrynalyne Guest

    Make a new thread in the software forum on it.

    I hate to be one to tell you so, but.....I told you so!

    You told me you didn't have a firewall, yet it was my first suggestion to check.
  26. fire-medic8104

    fire-medic8104 Private E-2

    I'll take that. I haven't used it in so long I didn't even know it was there.
  27. pa1ndru1d

    pa1ndru1d Private E-2

    Have you tried a non-windows media player? i.e. winamp? realplayer?
  28. fire-medic8104

    fire-medic8104 Private E-2

    yes,realplayer does the same thing.
  29. studiot

    studiot MajorGeek

    You need to have a serious talk with the control centre for your audio devices.
    Many have all sort of filter settings including 'through a tin can' and 'through a wet sock'..............updates often rechoose for ya!
    Also check if the download had 'upgraded' you from (say) stereo to 5.1 surround sound without beaming the extra speakers aboard.

    Studio T
  30. Adrynalyne

    Adrynalyne Guest

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds