1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Realtek HD Audio Problem

Discussion in 'Hardware' started by neosi, Oct 1, 2008.

  1. neosi

    neosi Private E-2

    Ok Here goes,

    Acer E380 with Dual Boot, XP (sp3) and Vista (sp1), onboard sound Realtek HD Audio

    All was working fine on XP (XP is the default OS) until yesterday, when the Realtek HD control panel kept popping up stating a new speaker had been plugged in (it hadn’t the same speakers that Ive been using for the last year hadn’t been unplugged and were still plugged in, rear sockets) this message kept popping up every 2 mins or so, sound was still working.

    Anyways I decided to unplug the speakers and plug em back. That seemed to sort the problem until the next reboot when I lost all sound.

    I have a dual boot with Vista so tried Vista and sound ok, no problems.

    Back in XP still no sound, unplugged the speakers to the front socket, had sound ok, plugged back into the rear socket no sound again. Checked the Realtek HD panel and according to that no speakers are plugged in !!

    Anyways searched Google and decided to try updating the drivers which I did but still no luck.

    Tried a new set of speakers, no difference

    When back to Vista and now Ive lost all sound there aswell.

    Ive checked everything I can think of, control panel, device manager all looks ok nothing is muted, nothing disabled.

    As far as I remember the last update I did was just after SP3 came out but that was 6-8 weeks ago, nothing else has been installed or updated recently so im completely lost with this one.

    Any help greatly appreciated

    Edit :- I have also checked the BIOS which was ok, but i then disabled the onboard sound rebooted, enabled it again, rebooted but still no difference.
    Last edited: Oct 1, 2008
  2. musksnipe

    musksnipe Guest

    XP SP3 needs a little convincing in order to install HD audio.

    Do this on your XP partition:
    Uninstall your Realtek audio driver.
    This patch is required before any of the HD device drivers are installed
    1. On your PC change the CSDVersion registry key to XP SP2:
    HKLM\SYSTEM\CurrentControlSet\Control\Windows\CSDVersion value=200
    2. Restart your PC
    3. Install KB888111xpsp2.exe Install Realtek High Definition Audio for 2K\XP\03
    4. Change the CSDVersion key back to XP SP3 again:
    HKLM\SYSTEM\CurrentControlSet\Control\Windows\CSDVersion value=300
    5. Restart your PC, finalize configuration of your PC, sysprep and capture.

    Simple Directions
    Goto Start>Run and type in regedit , then click OK.
    Click the plus signs in front of HKEY_LOCAL_MACHINE, SYSTEM, Current Control Set, Control, and finally, click Windows.
    In the right panel you will see CSDVersion.
    Right click it, choose Modify.
    In the highlighted input window, you should see 300. Change it to 200.
    Click OK, close regedit and restart your PC. Windows will now think it is SP2 and allow you to install the UAA (KB888111) and your HD audio driver.
    Realtek High Definition Audio for 2K\XP\03
    Make sure to reboot and then test your sound BEFORE, changing the value back to 300.

    Then follow the same steps to change it back to SP3. Change the 200 back to 300. (Make sure to reboot)

    Now, on your Vista partition, uninstall your audio driver and install:
    Realtek High Definition Audio for Vista

    If this doesn't get sound back on both partitions, we will have to deal with them one at a time.
  3. neosi

    neosi Private E-2

    Thanks musksnipe for the quick reply.

    Ive tried the XP fix, tested sound after rebooting but before changing the reg back to 300 but still the same problem. Ive also checked the Realtek CP and it still shows as no speakers plugged in, unplugged them again but still nothing.

    Will try fixing vista now and will report back.
  4. neosi

    neosi Private E-2

    Vista's Working... Your a Star :cool;):cool

    XP is still the same though.:cry :cry

    Theres Two things i dont understand though, if the SP3 release caused this problem why has my XP system only just started playing up when i installed SP3 weeks back and also how could this have affected Vista.

    Could I ask whats included in the KB888111 file, I assume its some drivers but I just want to check my system to make sure it has updated ok.

    Ive checked the Realtek Driver and its dated 24/09/2008
  5. musksnipe

    musksnipe Guest

    I'm not sure why it took a couple of weeks after your SP3 update for this problem to occur. The Update may not have caused the problem. Drivers can become corrupt for a lot of reasons.
    The problem is you can't reinstall HD audio under SP3, if it went bad. That's the reason for the fix. So that you can.

    The KB888111 is an older update and installs the MS Universal Audio Architecture (UAA) High Definition Audio class driver.
    Without it you can't have HD sound. It is supported in SP1 and SP2, but not SP3.
    The reg fix that I found, allows the MS UAA to be installed and then work under SP3.

    The best way to see if it has installed properly is to look in Device Manager>System Devices. You should see the MS UAA Bus Driver there. If you happen to see an unknown PCI device (probably in Other Devices), that is more than likely a bad install of the driver.

    Let me know, what is happening in Device Manager and we should get it straight.
  6. neosi

    neosi Private E-2

    Fully understand now why the need for the fix, thks,

    Will post a screen cap in a mo, I havent rebooted nor switched of since my last post, was using the pc for about an hour after posting, came back to it and im back where i was yesterday. Getting the Realtek CP popping up again. Only this time im getting intermittent sound (getting there) lol

    Anyhoo, Ive just checked Device Manager this is what i see under the MS UAA Bus Driver

    Driver Date 05/03/2004
    Driver Version

    Not seeing any unknown devices
  7. neosi

    neosi Private E-2

    The attached image shows the Realtek Control Panel. Speakers are already plugged in, approx every 30secs - 2mins this pops up, inbetween it popping up im getting sound then losing it again.

    Im hitting OK each time it appears, however ive been online now for 20 ish mins and it hasn't reappeared and I have sound, I haven't rebooted yet though and suspect when I do I'll either loose all sound or I'll be getting the CP popping up again..

    I'll let you now in a few minutes

    EDIT :: Just rebooted and sound gone again,


    Attached Files:

    Last edited: Oct 1, 2008
  8. musksnipe

    musksnipe Guest

    Ok. if I understand right, Device Manager is not showing ANY bad drivers.
    It is showing the UAA in System devices.
    Is Realtek showing in Audio, Video, and Game Controllers without any ? or ! in front of it?

    Are you sure there isn't a loose connection, either at the jack or at the back of the speakers or a break or fray in the speaker wires?

    Have you updated and ran any of your malware scanners lately? If you haven't, I suggest you should.
    These are two good ones and between them will find evidence of most any virus or spyware.
    Malwarebytes Anti-Malware
    Spybot Search And Destroy
    Do not install the Tea Timer on Spybot.
  9. neosi

    neosi Private E-2


    Yeah no bad drivers, everything is ok, ive checked under every device no ! or ? nothing in yellow.

    Have checked speakers and tried a new pair.

    Heres a list of AV and Spyware that runs everyday which hasnt found anything, Ccleaner also gets run after comming of the www

    AVG Antispyware
    Super Antispyware

    Since getting intermittent sound along with the CP yesterday, not had sound since.. Will be working today but will catch up later
  10. musksnipe

    musksnipe Guest

    We are only talking about the XP partition? Is there sound on the Vista one still?

    Could you attach an Everest report?
    Everest: http://www.majorgeeks.com/download.php?det=4181
    When Everest is done scanning, click "Report" at the top of the Everest window, click next to get to "Report Profile", select "Hardware related pages", click next, select "Plain Text", click "Finish". Then when it is done processing, click "Save To File". Save it where you want to. (I would use Desktop.)
    Now come back here to your thread.
    Click "Go Advanced" in the MG reply box (near the bottom of the page), scroll down a little way until you see "Manage Attachments", click it, browse to your file, click "Upload", and close the window. Then submit the post. You may have to also type something in the reply box.
  11. neosi

    neosi Private E-2

    Sorry for not getting back sooner

    Yeah Vista is still ok, just XP thats the problem, Speakers and hardware must be ok, Ive attached a Everest report for you. Only just got home but no sound again.

    I want to run a idea past you, would it be wise to totally remove MS UAA Bus Driver. Reboot, ignore windows if/when it auto detects new hardware but then reinstall the KB888111 fix. I could also uninstall the Realteck driver along the way aswell and reinstall after KB888111

    Attached Files:

  12. musksnipe

    musksnipe Guest

    Looking at your Everest report, it looks like XP is not seeing and using the chipset drivers for your motherboard.
    Go to ACER and input the required info (Desktop/Aspire E380) and download the Aspire E380/T180 Chipset Driver.
    Install it and see if you have sound.

    Yes, you could give that a try. Sometimes you may run into a problem getting the UAA to uninstall though.

  13. neosi

    neosi Private E-2

    That's interesting, back in May I installed a new DVD burner, but although it was recognized by XP, all burns failed. Worked the problem out to the chipset. The Acer site didn't have updated drivers so I got them from Nvida, that solved the problem and everything has been fine until now. I kept the nvida drivers so I'll try the acer ones and can revert back to Nvida if no joy..
  14. neosi

    neosi Private E-2

    No joy with the chipset drivers from the Acer site, ive also tried uninstalling the MS UAA Bus Driver as below

    Uninstall MS UAA Bus Driver (from device manager) > Reboot
    uninstall Realtek (from control panel) > Reboot
    Change CSDVersion to 200 > Reboot
    Reinstall MS UAA + KB888111 > Reboot
    Reinstall Realtek > Reboot
    Change CSDVersion back to 300 > Reboot

    Checked Vista again and all is ok, i havent changed the chipset driver back to how it was before updating with the Acer ones and have run a new report as attached


    Attached Files:

  15. musksnipe

    musksnipe Guest

    It still looks like the chipset driver is not installed on the XP partition.
    There is usually info here about your North and South Bridges
    And this would be pretty much empty here.
    Everything that is here would be hardware that the chipset drivers would enable to be recognized.

    Is it possible that the chipset installed to the wrong partition?
  16. neosi

    neosi Private E-2

    Not sure how to check but it i assume it must be on the right partition, The chipset drivers from Acer come in a zip file, ive extracted all files into a new folder on the XP desktop and run setup.exe from that folder. Ive run it again but it just does its thing without showing me where its putting the files

    The chipset installed in May that resolved the DVD burner issue was just a exe file and would have been run from the XP desktop.

    Surely if a chipset wasnt installed none of my hardware would work at all, could it be that Everest isnt reading it for some reason
  17. musksnipe

    musksnipe Guest

    That's a good possibility. But usually when I see something like that in a report and the chipset is installed, it resolves the issues.
    Did you try reinstalling the nVidia drivers after the Acer ones or did you just do a restore/rollback?
  18. musksnipe

    musksnipe Guest

    Here are a couple of things to check:
    Check that Windows Audio Service is started.
    Go to Control Panel>Administrative Tools>Services
    Scroll down the list of services until you find the Windows Audio service.
    Right click on it and choose Properties.
    Make sure it is set to Automatic and Start is checked.
    Check: Control Panel>Sounds and Audio Devices:
    In the Control Panel>Sounds and Audio Devices, click the Volume tab.
    Make sure the box for placing the volume icon in the task bar is checked.
    Click Advanced in Device Volume area.
    Make sure that you have Volume Control, Wave, SW Synth, and CD Player all listed in the Control. Make sure none are muted and the volumes are at a listenable level.
    If not there, click Options>Properties and mark the boxes for them.
    Click Advanced in the Speaker Settings area.
    Make sure that the speaker type you use is selected.
    Check the Audio tab.
    See if your sound device is listed in the Sound Playback Default Device list.
    Check the Hardware tab.
    See if sound device is listed in the list. If it is make sure it is enabled.
  19. neosi

    neosi Private E-2

    Double checked again any everything is how it should be,

    I hadnt put back the nvida chipset but have done now (reinstalled from the original exe)

    If it was'nt for the fact that sound on Vista is working ok id have given up and just assumed it was the hardware itself thats gone up in smoke.
  20. musksnipe

    musksnipe Guest

    I don't have much practice dealing with dual OS/partions and sound, so I went on a Google hunt.
    I saw quite a few problems, just like yours, involving dual boots, using Linux, XP (32- and 64-bit), and Vista. The Vista partition always had sound but the other partition loses it.
    Unfortunately, I didn't see any fixes.

    Looking back through Everest, I see the Microsoft WINMM WDM Audio Compatibility Driver listed.
    Is that showing in Device Manager?
    If it is, uninstall it.
    It can create a conflict with your normal driver. It is usually only used when there is not a dedicated audio driver installed.

    This is a last resort fix, that I have posted, and seen work when no others did.
    Make sure to set a restore point, first.]

    Plug and Play Software Device Enumerator
    Scenario One
    You DO have "Plug and Play Software Device Enumerator" listed under System Devices

    Carry out the following steps;
    * Copy C:\WINDOWS\inf\machine.inf to a temporary location
    * Edit your copy of machine.inf in Notepad
    * Remove line 20 (ExcludeFromSelect=*)
    * Right-click “Plug and Play Software Device Enumerator” and click “Update Driver”
    * Choose “Install from a list or specific location (Advanced)” and click Next
    * Choose “Don’t search. I will choose the driver to install” and click Next
    * Click “Have Disk”
    * Browse to the location of your copy of machine.inf and click OK
    * Select “Plug and Play Software Device Enumerator” and click Next
    * Wait for the software to install then click Finish

    Scenario Two
    You DON’T have "Plug and Play Software Device Enumerator" listed under System Devices

    Carry out the following steps;
    * Copy C:\WINDOWS\inf\machine.inf to a temporary location
    * Edit your copy of machine.inf in Notepad
    * Remove line 20 (ExcludeFromSelect=*)
    * Go to the Control Panel and run “Add Hardware”
    * When the Add Hardware Wizard appears, click Next
    * Wait for it to search for new hardware
    * Choose Yes, I have already connected the hardware and click Next
    * Scroll all the way down and select “Add a new hardware device”, click Next
    * Choose “Install the hardware that I manually select from a list (Advanced)”, click Next
    * Select “Show All Devices” and click Next
    * Click “Have Disk”
    * Browse to the location of your copy of machine.inf and click OK
    * Under Model, select “Plug and Play Software Device Enumerator”, click Next
    * To start installing the drivers, click Next
    * Wait for the software to install then click Finish

    Check your sound, if no go, try another install of the Realtek driver.
  21. neosi

    neosi Private E-2

    I cant see Microsoft WINMM WDM Audio Compatibility Driver in Device Manager, would it be under system devices if so its not there.

    Is ok to continue with the below ? as its not shown

    I'll be back online in around 1 hour so will try the below and get back to ya..
  22. musksnipe

    musksnipe Guest

    Microsoft WINMM WDM Audio Compatibility Driver would be in the Sound, Video, and game Controllers section. If it's not there, it probablly isn't the problem.

    Yes, give the other fix a go.
  23. neosi

    neosi Private E-2

    Same old story im afraid,

    I do have "Plug and Play Software Device Enumerator" so followed those steps, rebooted when prompted and uninstalled/reinstalled Realtek but nothing different.

    However i may be clutching at straws but i did spot something, at the point where you Click “Have Disk” that page shows "Plug and Play Software Device Enumerator" in a box in the main window, however, its shown twice.

    Ive checked Device manager and its only shown once as it should. I went back did it all again but selected the second entry for "Plug and Play Software Device Enumerator" at the "have Disk" stage but still no luck.. :cry
  24. musksnipe

    musksnipe Guest

    I found this post. Could this be the answer?
    Sorry, I'm out of ideas here. :(
    The only thing I can think of, is that the Vista audio is in control, even on the XP partition, and won't play there.

    If you're adventurous, you might try uninstalling the Vista audio driver and seeing if your XP driver/partition has sound after that. rolleyes
    Then you would have some idea of what is going on.

    The only thing wrong with that idea is: "Will the Vista partition allow you to reinstall it?" :eek
  25. neosi

    neosi Private E-2

    Hi, I've tried disabling and deleting the UAA drivers as below but still the same story,

    Thanks for your help, really appreciate it. I'll stick at it and if and when its sorted I'll post back
  26. kroghert

    kroghert Private E-2

    Worked perfect on my Fujitsu Siemens Scaleo T, xp sp3. Huge thanx :)

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds