1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Router - Cant connect to PC

Discussion in 'Hardware' started by sheepondrugs, Jun 1, 2007.

  1. sheepondrugs

    sheepondrugs Private First Class


    lets start from the beginning..

    every month i log into the d-link router ( to do a quick check up see if everything is running fine,

    however, yesterday rebooted the router and nothing would work, no internet, no network,

    tried to log into the router 404 page not found, connected it by cable, "limited or no connectivity"

    tried to install from the official disk, "router not found, please connect and try again"

    downloaded a program called "angry IP" scanned all the IP addresses possible, (dead or live) no active Ips found,

    the router is on, and looks to be working fine, but just not recognised by the computer,

    i have tried to do a hard reset, but nothing has changed.

    any ideas?confused


  2. foogoo

    foogoo Major "foogoo" Geek

    Can you put a static IP ( like and ping Is this wired?
    If it will answer a ping and still not respond otherwise you can attempt to download the firmware from Linksys and TFTP it back to the router.

    I had a router do this while flashing it with ddwrt.. it would not give me a web interface yet I could ping it, so I FTP'd up the manufactures firmware and it was back working again.

    *This is a black diamond stunt - proceed at your own risk*
  3. KingSteve

    KingSteve MajorGeek

    sounds like your dhcp turned off and youre not getting an IP from the router. that might explain not being able to get the web page. do what foogoo said and put in a static ip and try from there.
  4. BILLMCC66

    BILLMCC66 Bionic Belgian

  5. sheepondrugs

    sheepondrugs Private First Class

    set up the static IP

    pinged the router, ( and

    either "request timed out" OR "destination host unreachable"

    any ideas? confused

  6. Colemanguy

    Colemanguy MajorGeek

    Set it back to dhcp, and check if your getting an ip by doing the following.
    Start run cmd, then enter key, then in the command line type ipconfig
    This will actually check if your not getting dhcp instead of assuming thats the case :) Lets start with that.
  7. sheepondrugs

    sheepondrugs Private First Class

    dhcp enabled - yes
    autoconfig enabled -yes
    autoconfig IP -
    subnetmask -
    default gateway:

    default gateway is blank,

    some guy on another forum had the same problem, he rang up tech support and they said to do a hard reset (although it didnt work for me)

  8. cat5e

    cat5e MajorGeek means that the computer have No DHCP server (usually in the Router) to obtain an IP from.

    Seems that your computer can not conncect to the Router (or the Router is busted).

    Check the cables, try a static IP and see what is happening.

    To check the computer network this migh help.

  9. BILLMCC66

    BILLMCC66 Bionic Belgian

    one of the things the tech asked me to do was connect via Ethernet cable which we did but we could still not connect to the router.

    when i used CMD-IPCONFIG i repeatedly got the same autoconfig IP address you are getting and the same sub net mask, we found that we could set everything to 0 but if we reset it to the moment we tried to connect it went back to the bad IP.

    i hope you find an alternative i did a reinstall but only because i have a second hard drive with a complete backup (i backup every night) so for me it was not a traumatic experience just a bit inconvenient.

    i wish you good luck and hope you solve it if you do please will you post the solution just for future reference.;)
  10. KingSteve

    KingSteve MajorGeek

    the router could be bad. it shouldnt be giving you this much trouble. if youre setting your ip at it will give you problem as well. that would be the default ip of the router. set your ip at and make sure your computer is the only one on it. then run an ipconfig and see if it took the ip. if youre still getting a 169.254 number, there could be a problem with the NIC. disable and renable and try again. if it still wont take the ip, it could be a bad NIC. try with a different computer. also make sure your firewall will allow icmp traffic.
    if you get the ip set at and see it in your ipconfig and still cant ping, the problem could be with the router. try to get your hands on a different one and try again.
    there could also be a problem with the cable youre using. try a different cable as well.
    remember that there will be problems when youre setting static ips in an environment where dhcp is running.

    Edit: post 100 woot!
  11. sheepondrugs

    sheepondrugs Private First Class

    personally i think the router is broken then, :(

    we have 6 computers in the house, xp and vista

    (cable) pluged the router into my computer (without firewall enabled)
    no joy, tried another computer, no joy

    bought a new router, worked fine first time,

    i think the routers software has crashed/corrupted.

    the most annoying thing is that the router is less than 1 year old, thanks D-Link :-\

    anyways, thanks for all the feeback was worth a try,

  12. cat5e

    cat5e MajorGeek

    On the computers there is No Router software or drivers or any thing functional related to the Router.

    The Router itself has firmware embedded in its system that make it run.

    Could be that the firmware got corrupted.

    Read the manual about Hard Reset and do it.

    Hard Reset of the Router might revive it.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds