1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RT2500 for WMP54G BSoD

Discussion in 'Software' started by supersprynt, Mar 27, 2009.

  1. supersprynt

    supersprynt Private E-2

    Summary: I have a Dell Precision 530 that I have upgraded in every which way.

    I'm using WinXP and a Linksys WMP54G wireless card. I has been working fine until now. Few weeks ago I upgraded the software etc - worked fine. This week I moved. I can't get the internet to work but that's another story.

    Currently I will get the BSoD whenever I attach my wireless card's antenna. I've done it several times, this is the exact moment. I disconnect it and boot up - no problem. Attach antenna BSoD indicating a RT2500.sys problem.

    Ok - uninstalled all the software/drivers - installed original software/drivers, switched PCI slot. Same thing. Downloaded driver from Cisco's website, installed it - same thing.

    I'm about ready to give up on this card and plunk down $80 on an N-draft card but thought this would be a last result. Any help is appreciated.

  2. lbmest

    lbmest MajorGeek

    Pulled this quote from Linksys forum. (My bolding on the Safe Mode.)

    Had the some problem with BSOD. WMP54G did not have a version number where instructions on Linksys web site said it should be. Downloaded the version 4.1of the driver and extracted the folders and files to the hard drive. Booted into Safe mode and went to device manager and uninstalled the WMP54G PCI adapter. Ran setup.exe in Utility folder to remove drivers for WMP54G PCI adapter. Then went into the drivers\wmp54gv4.1 folder and right clicked on the rt61.inf and choose install from the drop down menu. Then went to device manger and chose ‘scan for hardware changes’ from the Action menu. Computer detected the WMP54G PCI adapter and I had to point the install to the drivers\wmp54v4.0 to load the notorious rt2500.sys. Computer finished installing the driver and asked to reboot. This was all done in Safe Mode. I restarted the computer and much to my amazement the computer booted successfully and I am now connected to my wireless network with the WMP54G PCI adapter. Hope this helps all the people that are pulling their hair out with this thing like I was.
  3. supersprynt

    supersprynt Private E-2

    Thanks for that. Unfortunately I know which version I have (v4) and have installed the original and updated drivers for the unit, to no avail.
  4. supersprynt

    supersprynt Private E-2

    I'm going to go out on a limb and say you didn't read the first response.
  5. ahelpinghand

    ahelpinghand Private E-2

    This actually works guys. Go into safe mode, uninstall your whatever network adapters that Windows has installed, reboot back into safe mode.

    Now make sure you have downloaded the v4.1, which actually has v4.0 drivers in it for some reason, AND these ones actually work. Make sure you do the install in safe mode.

    It actually worked for me and I spent a good 10 hours trying to figure it out.

    THANKS lbmest!

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds