1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sound driver missing - no active mixer devices avail

Discussion in 'Software' started by Antbebee, Oct 16, 2010.

  1. Antbebee

    Antbebee Private E-2

    Please help me. :cry
    I had a bad virus/worm. I think it was Internet Security 2010 virus.
    A friend finally got rid of the virus, but mentioned that she thought it had gotten into my sound driver.
    Now I have no sound. I have attempted to correct this by going to Dell and downloading the driver, then tried to download the chipset, rebooted, then downloaded the driver, but it did not work.
    I have ran the Everest as requested. I have attached 4 report files from running Everest.
    Dell, Dim 4700, P4, 520 (2.8GHZ), HT, INT SNDNICV, BIOS version # A09
    Windows XP SP3, Integrated Audio,
    Recent error message: No active mixer devices available
    Please forgive me if I have not provided everything you needed. :-o
    I want to THANK YOU in advance for any help you can provide ! :)

    Attached Files:

  2. mastermosley

    mastermosley Sergeant

    Try this:

    1. Right-click My Computer, and then click Properties.
    Click Start, click Run, type sysdm.cpl, and then click OK.
    2. On the Advanced tab, click Settings under Startup and Recovery.
    3. Under System Startup, click Edit.

    Your boot.ini should look something like:

    [boot loader]
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

    Remove the "/fastdetect". Save the file. Go to devices and unistall your sound driver. Restart the computer and it should automatically install. If not:

    Download and install this driver:ADI integrated audio http://support.dell.com/support/dow...stemID=DIM_P4_4700&os=WW1&osl=en&catid=&impid
  3. Antbebee

    Antbebee Private E-2

    Thank you for responding so quickly ! :)

    I tried the first option, to delete the sound driver.
    I deleted the "Unimodem" sound driver.
    I tried to delete the "Legacy Audio Drivers" but it didn't have anything to delete inside.
    After I re-started the computer, it "found" the "Unimodem" again. But I still have no sound.

    Then I deleted the sound driver again, and attempted the link you listed, but it said it could not find it, that it must have been moved.


    Do you have any other ideas or know where that link moved to ?????

    Thanks for all your help !
  4. Caliban

    Caliban I don't need no steenkin' title!

    Greetings, Antbebee.

    The driver page for the Dimension 4700 is located here - click on 'Download', and on the resulting page, click 'Download using your browser'.
  5. Antbebee

    Antbebee Private E-2

    Thank you for sending me this second link, to Dell's driver page. However, I have already tried this before and it did not work. Just in case, I tried it again since receiving your message, but unfortunately, it still won't work.


    Do you have any other ideas ????

    Thanks for your help !
  6. Caliban

    Caliban I don't need no steenkin' title!

    Have you looked in BIOS, made sure onboard audio is enabled?
  7. Antbebee

    Antbebee Private E-2

    I have attached a report using Everest to show my BIOS.

    What should I do ??:confused

    Attached Files:

  8. Caliban

    Caliban I don't need no steenkin' title!

    Thanks for the report - but, is onboard audio enabled?
  9. Antbebee

    Antbebee Private E-2

    Sorry ! :-o I obviously don't have a clue. lol
    I am just doing my best to stay afloat here.
    I thought that report would tell you what you were asking.

    Could you please tell me how I can find out if the onboard audio is enabled on my bios ?? :confused

    Thank you for your patience ! ! !
  10. Caliban

    Caliban I don't need no steenkin' title!

    Reboot the machine, and when the Dell splash screen appears press the <F2> function key. If you wait too long and the Windows logo appears, allow the machine to start and repeat the process.
    In the System Setup menus, look for an Audio Controller (or similar) entry - make sure it's enabled, save and exit.
    The machine will then reboot to Windows - check the audio, see if your symptoms have changed.
  11. mastermosley

    mastermosley Sergeant

    Did you edit the bootloader? And the link seems to work for me:confused

    If none of this is working you could always try a system restore. Which will rollback your computers settings to previous time. If that doesn't work you may have to restore the computer all together using your restore disk. Question, do you not have a dell resource cd? that should have all your drivers on it.
  12. Spad

    Spad MajorGeek

    Have you checked under services and made sure the Windows Audio service is running?

    I have had a couple of incidents where virus activity has corrupted that part of the registry - without that service running your audio will not work.

    Go to Run - type in services.msc and press return. Scroll down the list of services and make sure Windows Audio is there, started, and set on automatic.

    If the service does not appear at all, go to this post (#16 in the thread):

    Follow the directions there, AFTER you have backed up your registry. If you don't know how to backup the registry, download ERUNT from MG here. It's a good, small registry back-up program, easy to use.

    The above instruction will restore the Windows Audio to the services list. Often, like I said, virus activity or poorly written software can damage parts of the registry.

    Let us know how it's going. :)
    Last edited: Oct 18, 2010
  13. Antbebee

    Antbebee Private E-2

    :) Thanks to everybody that replied, but nothing is working yet. :(

    I still can't get the link to work that was listed as:
    Download and install this driver:ADI integrated audio http://support.dell.com/support/down...n&catid=&impid
    It took me to this site, and said "The resource cannot be found" :confused

    I checked in Run, services.msc. The Windows Audio is there, started and on Automatic.

    I Rebooted, F2, System Start up menu, Audio Controller, I enabled it, saved & exited, then rebooted. When it came back up it said,
    "Found new hardware, Unimodem Half Duplex"
    Then it said:
    "Found new hardware, Sound Max Integrated Digital Audio"
    But then it said:
    "File needed: smax4pnp.exe"
    It said it could not find it on the C drive and could I put in the Installation Disk. I tried the 2 different Installation Disks that I have, but that file was not in either one.

    Do ya'll know where I can find that file ?? :confused
  14. mastermosley

    mastermosley Sergeant

    You should have a disk labeled "Dell Rescource CD" Which contains all your drivers. Did you try a System Restore?
  15. Antbebee

    Antbebee Private E-2

    I could not find a CD labeled Resource, but I did finally notice in my programs that I have a Dell Driver Reset. Once I ran that, I now have sound.

    I feel SO dumb. :-o I am so sorry for wasting your time on this forum.
    I apologize ! :-o

    I appreciate all the tips and information from all the guys on this forum.
    It meant so much to me that ya'll were so willing to help. :)

    Thanks again for everything ! :wave
  16. Caliban

    Caliban I don't need no steenkin' title!

    Glad you got it - thanks for the feedback. :major

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds