1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Startup Repair Infinate Loop can't Enter Safe Mode

Discussion in 'Software' started by SLoTH_XVX, Jun 25, 2012.

  1. SLoTH_XVX

    SLoTH_XVX Private E-2

    I have a Toshiba laptop running Windows 7 that is stuck in a Startup Repair Loop. I have read through some of the postes here and other sites including Microsoft and not been able to 1) Stop this infinite loop or 2) access Safe Mode.

    I thought it would be better to begin a new thread instead of adding to an existing one.

    I have gotten to the point where the Startup Repair says it has found a solutiona nd will reboot to complete but it continually returns to the Startup Repair 'software' after rebooting.....

    Any one been able to get out of this loop?

    I do not have a recovery disk or other disks. We did not receive and disks as everything was loaded on the laptop when we purchased it.
  2. tgell

    tgell Major Geek Extraordinaire

    See if the process here will help. It is a long article so it may help to read through it first. You can click on any image to get a larger view. In step 14 it says to type the command.

    copy *.* ..

    You have to include a space after the last * and then two periods. This copies the files to the parent directory of Regback which is config.

  3. SLoTH_XVX

    SLoTH_XVX Private E-2

    Thanks 'tgell' I have tried this and it did not correct the issue.
  4. tgell

    tgell Major Geek Extraordinaire

    I do not like to mess with the MBR of an OEM computer because it might cause your recovery partition to fail. Toshiba has the option of doing a factory reset. All data would be lost since purchase but it can be backed up using a small linux distro like Puppy. Would you be willing to try a factory reset after you back up your data?

    Also, this might be a problem with the BCD but I do not have much experience with that. sach2 hopefully will see this and jump in. He may have some ideas on fixing the problem.
  5. SLoTH_XVX

    SLoTH_XVX Private E-2

    I think I figured out what MBR is but what is BCD?
  6. tgell

    tgell Major Geek Extraordinaire

    BCD Boot Configuration Data store. It has the boot configuration parameters and controls how the operating system is started. In XP it was done with the Boot.ini file. Windows Vista and Windows 7 went to BCD which I think is way more complicated.

    At the command prompt, type BCDEDIT and post the contents. It may help.
  7. SLoTH_XVX

    SLoTH_XVX Private E-2

    I would be willing to do the factory reset but I will need guidance on how to do the back-up.

    I will post the contents via the BCDEDIT command prompt.....how do I get the info from the command window to here if I can not access anything on the computer?
  8. tgell

    tgell Major Geek Extraordinaire

    That's a very good question. I forgot about that. I am going to have to do some research on this. Hopefully we can get it to a USB flash drive or you can write it down and type it worse case. I will be coming back tomorrow. Hopefully sach2 may jump in with his thoughts.
  9. SLoTH_XVX

    SLoTH_XVX Private E-2

    It is not that much I can simply retype here.

    Windows Boot Manager
    identifier {bootmgr}
    device partition+D:
    description Windows Boot Manager
    locale en-US
    inherit {globalsettings}
    default {default}
    resumeobject {12800476-f24b-11df-b935-9f54c4a67c27}
    displyorder {default}
    toolsdisplayorder {memdiag}
    timeout 30

    Windows Boot Loader
    identifier {default}
    device partition=C:
    path \windows\system32\winload.exe
    description Windows 7
    locale en-US
    inherit {bootloadersettings}
    recoverysequence {current}
    recoveryenabled Yes
    osdevice partition=C:
    systemroot \windows
    resumeobject {12800476-f24-11df-b935-9f54c4a67c27}
    nx OptIn
    winpe No
  10. tgell

    tgell Major Geek Extraordinaire

    Have you tried safe mode by tapping F8 at boot? If not, go into safe mode and select Last Known Good Configuration. If it still loops, go into safe mode again and select Disable automatic restart on system error. It may throw up a blue screen with an error.
  11. SLoTH_XVX

    SLoTH_XVX Private E-2

    Can not access Safe Mode at all.
  12. tgell

    tgell Major Geek Extraordinaire

    For backing up your important data, do you have a external USB drive?
  13. SLoTH_XVX

    SLoTH_XVX Private E-2

    Yes, I has a 2gb USB Flash and also several external Hard Drives.
  14. tgell

    tgell Major Geek Extraordinaire

    First can you do the following. Disconnect any external drives. Type the following in a command prompt.

    list disk
    select disk 0
    I believe this will be the disk to select as you only have one hard drive.
    detail disk

    What is shown under Volume## and the rest of the headings?
  15. SLoTH_XVX

    SLoTH_XVX Private E-2

    Under Volume ##:

    Volume 1 - C - TI105952W0C - NTFS - Partition - 22 GB - Healthy
    Volume 2 - D - System - NTFS - Partition - 1500 MB GB - Healthy - Hidden
  16. tgell

    tgell Major Geek Extraordinaire

    That is kind of weird that the drive is listed as only 22GB. Too small for a Windows 7 install. When you did the "detail disk" command did it list Volume 1 as being a system disk. That would show up after the healthy listing. What was the size of disk 0 and the amount of free space available under the "list disk" command? The hidden partition is only 1.5 GB so I believe if this is in fact the recovery partition, it is not Windows 7 but maybe XP. Was Windows 7 installed on this computer later.
  17. tgell

    tgell Major Geek Extraordinaire

    I will be stepping out for a couple of hours.
  18. SLoTH_XVX

    SLoTH_XVX Private E-2

    Sorry my mistake....that should have been 222 GB not 22
  19. tgell

    tgell Major Geek Extraordinaire

    That sounds okay but the 1.5GB repair partition has me a little worried. If you used that, you may not be getting Windows 7. What is the make and model of the Toshiba.

    After the command select disk 0

    list partition

    What is listed? Is should list Partition 1 and Partition 2. Type:

    Select Partition 1
    list Partition 1

    What is listed under the headings? Does it say System under the Info heading?

    Now type:
    Detail partition
    Does it list the partition as Active:Yes?

    Select Partition 2
    Detail Partition

    Is the size 15GB or 1.5GB?
  20. SLoTH_XVX

    SLoTH_XVX Private E-2

    It lists 3 partitions:

    Partition 1 - Recovery - 1500 MB - 1024 kb (offset)
    Partition 2 - Primary - 222 GB - 1501 Mb (Offset)
    Partition 3 - Primary - 9 GB - 223 GB (Offset)

    After typing "list Partition 1" I get the following
    "The arguments specified for this command are not valid. For more information on the command type: HELP LIST PARTITION"
  21. tgell

    tgell Major Geek Extraordinaire

    Did you type Select Partition 1 and then list partition 1?

    Edit: I would type Select Partition 2 and then list partition 2. Is partition 2 listed as active?

    When you look on the bottom of the laptop, does it show a Windows sticker with the key? It should also list the OS. What OS is listed on the sticker?
  22. tgell

    tgell Major Geek Extraordinaire

    sorry, the command after select partition 2 would be Detail Partition This should note if the partition is active.
  23. SLoTH_XVX

    SLoTH_XVX Private E-2

    OS is Windows 7 Home Edition (Premium)

    Yes I did type Select Partition 1 and then list partition 1...

    I just tried select partition 2 and then detail partition 2 and received the same message as I did with the partition 1 prompts.

    I also tried the same for partition 3 and got the same message....
  24. tgell

    tgell Major Geek Extraordinaire

    It's not Detail Partition 2, just Detail Partition. So the commands would be.

    List Disk
    Select Disk 0
    List Partition
    Select Partition 2
    Detail Partition

    It should list it is Active:Yes
    Status: Healthy
    Info: System
  25. SLoTH_XVX

    SLoTH_XVX Private E-2

    Got it, sorry for the mix up...again.

    The activity is listed as 'NO'
    The status is 'Healthy'
    The infor is blank
  26. tgell

    tgell Major Geek Extraordinaire

    Can you do the same thing for partition 1 and partition 3 and give the results? Do any of those partitions show active as yes?
  27. SLoTH_XVX

    SLoTH_XVX Private E-2

    Partition 1
    Activity 'YES'
    Status 'Healthy'
    Info 'Hidden'

    Partition 3
    Activity 'NO'
    Status and Info not listed
    "There is no volume associated with this partition"
  28. tgell

    tgell Major Geek Extraordinaire

    I did some research and it seems there are three partitions listed for Toshiba and the 1.5GB partition is the boot partition. This was listed in your post.

    Volume 2 - D - System - NTFS - Partition - 1500 MB GB - Healthy - Hidden

    I am afraid if we alter the BCD it will keep the recovery partition from working. Can you do the following but do not complete the factory reset. Just see if you can get it to boot into the Recovery Manager.


    If it works, then we can transfer the files you want before the factory reset. If not then we will have to try editing the BCD or rebuild it.
  29. SLoTH_XVX

    SLoTH_XVX Private E-2

    Followed the steps from the link you supplied and am able to get to the TOSHIBA Recovery Wizard.

    The window says:

    When the recovery is exicuted. all data will be deleted and rewritten.
    If you are restoring from a backup, did you make sure to backup all important data and configure Windows the way you want it restored?
    Please conect the AC adapter.

    Then there are a YES and NO buttons.

    I have not selected either....yet.
  30. tgell

    tgell Major Geek Extraordinaire

    Okay, Just power off the computer.

    Edit: I will post back shortly.

    Download Puppy Linux and burn the iso with Imgburn.

    How to write an image file to a disc using ImgBurn

    Boot the CD and connect the USB external drive. Transfer the files from the different user accounts. This would include Documents and Settings and anything on the Desktop.

    Here is a good link on using Puppy to transfer files. After you have double checked that you have transferred all of your data, then you can go through the Factory Restore Sequence you just did pressing the Yes button. Here is a good link on how to transfer files and what to transfer with Puppy. Please post back if you have any questions.

    Last edited: Jun 27, 2012
  31. tgell

    tgell Major Geek Extraordinaire

    Just a reminder. Any programs added after purchase will be lost.
  32. SLoTH_XVX

    SLoTH_XVX Private E-2

    I am back in business!

    Thank you for all your help tgell. Sorry we took the long way around with my mix up of information but I am up and running and looking good!

    Was successful in saving all important documents and files and now am working on reinstalling all the software that was removed through the Factory Restore.

    The only difficulty I had was getting the laptop to get back to the Factory Reset screen. For some reason it would not boot to the Factory Reset screen the first couple of times. I just kept trying until I got to the reset screen.
  33. tgell

    tgell Major Geek Extraordinaire

    That's Great! I was hesitant to try editing the BCD because I am not too confident in that and I did not want to break the ability of the laptop to do a factory reset.

    Just a reminder. Also do a Windows Update to get all of your security updates.

    I would also make a System Repair Disk just in case the computer does not boot due to a problem in the future.

    Create a System Repair Disc in Windows 7

    You can also use Windows built in imaging tool to create a complete system backup. Should you have problems, you could use the System Repair Disk to restore the system image and not have to do a complete factory reset. If you do this, you should back up all partitions together in order not to break the factory reset partition.

    How to Create a System Image in Windows 7

    How To Restore Windows 7 from a System Image

    Another good link.

    How to Create a System Image of a Hard Disk Partition or Windows 7 Partition

    Just a question. What did you think of Puppy Linux?
  34. SLoTH_XVX

    SLoTH_XVX Private E-2

    Puppy Linux was super easy to use after reading the info from the link you provided. Pretty simple interface, nice to not have to doublew click every choice and just click once to open a file or document. I am sure with time and usage it would become just as familiar as Windows.

    I am having a problem though with Windows 7 not acknowledging me as Administator when installing software and especially causing headaches when running Immunize with Search and Destroy. I am logged in as the administrator but Windows keeps telling me I need to be logged in as the administrator to run 'exe' and complete the Immunizor through Search and Destroy. Any ideas?
  35. tgell

    tgell Major Geek Extraordinaire

    I am not familiar with Search and Destroy or Immunize. Personally, I do not use software like that. Maybe that was the cause of the problem. I use a good anti-virus with Windows 7 own firewall and set up a Limited User Account for all of my browsing.

    Have you created another Administrator Account and see if the installs work for that? The current Administrator account could be corrupted for some reason.

    Do you still have problems installing the software if you right click on the install file and select "Run as Administrator"
  36. SLoTH_XVX

    SLoTH_XVX Private E-2

    SpyBot Search & Destroy is one of the recommended Malware scanners recommended through MajorGeek's in Major Attitudes and chaslang's cleaning procedures that I have successfully used for years. Immunize is part of SpyBot Search & Destroy, it sets passive internet protection.

    I was having difficulties with Administrator 'rights' prior to installing SpyBot Search & Destroy but have been able to right click on the intall files and Run as Administrator but Windows 7 is not acknowledging admin status on my primary account or another one I set up as admin....?
  37. tgell

    tgell Major Geek Extraordinaire

    When you say it is not acknowledging you as Admin, do you mean that the UAC dialog box pops up when you try to install something, asking for your password? I believe on a lot of programs, this is normal, especially if it changes anything regarding the system.
  38. SLoTH_XVX

    SLoTH_XVX Private E-2

    When I attempt to install some software it is bringing up a window that says I need to be logged in as an administrator (which I am) and the title of the window is 'Can't Install' (or something like that).

    Sorry, I don't know what a UAC dialog box is.....
  39. tgell

    tgell Major Geek Extraordinaire

    I believe this is a permissions problem and I am not that great with permissions. The UAC is a control box that pops up if you try and change any system settings, asking for the administrator password. You should not disable it. Hopefully somebody with experience in permissions will jump in here. I am going to have to do a little more reading on this. I will be signing off until tomorrow.

  40. tgell

    tgell Major Geek Extraordinaire

    If you temporarily disable UAC, are you allowed to install programs?
  41. SLoTH_XVX

    SLoTH_XVX Private E-2

    Yes, temporarily disabling the UAC does give me access to install without selecting 'Run as Administrator' and save files (into admin areas like the Windows Folder).

    The biggiest issue is not so much installing programs as much as saving, copying, pasting and deleting folders and files in what Windows is deeming 'admin' areas.

    One thing I noticed when switching back to original UAC setting is that my login was set to the default setting which states:

    Notify me only when programs try to make changes to my computer.
    Don't notify me when I make changes to Windows settings.

    At this setting it is doing just the opposite....it is not allowing me to make changes to Window settings.
    Last edited: Jun 29, 2012
  42. tgell

    tgell Major Geek Extraordinaire

    That is really strange. In an admin account go to Computer and right click on your C drive. Select Properties. Click the security tab. Click the advanced button. Under the owner tab Current Owner should be TrustedInstaller.
  43. SLoTH_XVX

    SLoTH_XVX Private E-2

    Yep Current Owner is TrustedInstaller.

    In the box below the Current Owner field is 'Change Owner To:' box which lists my User ID (which should be set up as an Administrator). Does this sound like it is correct?
  44. tgell

    tgell Major Geek Extraordinaire

    Yep, that is correct. I really don't understand what is going on. When you look at the administrator account under the security tab, do you see all the boxes checked except the last one (special permissions)?

    When you click the advanced button, under permissions, you should have full control for administrators and system (this folder,subfolders and files). There should also be a listing for Authenticated Users with special permission for subfolders and files.

    Edit: I am signing off until tomorrow. There is one thing that we can try but I am not sure it will work. There is a software utility that will repair permissions.
  45. tgell

    tgell Major Geek Extraordinaire

    One other question and I am not sure if it makes a difference or not. After you did the factory reset, did you copy over complete folders before you started installing programs and if yes, what were they?
  46. SLoTH_XVX

    SLoTH_XVX Private E-2

    I'm sorry tgell, but you completely lot me here....can you walk me through how to locate this info? The only thing I can seem to find is a slider bar for setting User Account Control......I think I am missing something......

    No, I did not copy over folders until I had several programs installed.
  47. tgell

    tgell Major Geek Extraordinaire

    Right click the hard drive. Select properties. Under the security tab, press the advanced button. Under the permissions tab, there will be an administrator entry. It should show full control (this folder,subfolders and files). There should also be a listing for Authenticated Users. What is listed?
  48. SLoTH_XVX

    SLoTH_XVX Private E-2

    Ahhhhh, sorry. I was completely lost. Thank you for the step by step.

    I have two Authenticated listings

    1) Has 'Special' permissions that apply to 'Subfolders and files only'
    2) Has 'Create folders / append data' permissions that apply to 'This folder only'
  49. tgell

    tgell Major Geek Extraordinaire

    That is right. I am at a loss as to what is going on. There is a utility called D7 that can repair permissions but I am not sure if it will work in your case. It may break something else but you can always try another factory reset. This is up to you. I would first uninstall Spybot and Immunize just in case this keeps the registry from being modified. Download Windows Repair All in One. Turn off UAC and Right click the exe file. Select Run as administrator. Only check Reset the file and registry permissions under the repairs tab.

  50. SLoTH_XVX

    SLoTH_XVX Private E-2

    I give it a try....like you said I cn always do another factory reset.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds