1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to delete folders from external hard drive

Discussion in 'Hardware' started by razoric, Oct 1, 2010.

  1. razoric

    razoric Private E-2


    I have 3 external hard drives which i have mounted onto my c drive

    The reason i did this was so that media player could index the files, and then i could share my music to my ps3 by making media player a media server. Previously depending on which drive i switched on win xp would auto assign the next available letter and i was constantly having to change the monitored folders/drive in media player in order that they are shared on my network with my ps3.

    Anyway, that's the background, and this has worked well for me for a few weeks, but when i tried to delete a folder from one of the mounted drives it says;

    " cannot delete (folder name)
    make sure the disk is not full or write-protected and that the file is not currently in use"

    I checked the folders attributes and unselected any that were read only, but still did not allow me to delete.

    Here's the bizarre bit, if i go into the folder, i can delete individual files until the folder is empty, but even then can't delete the folder itself??

    I thought the folders may have been "in use" by windows indexing, so told windows not to index them, but this didn't resolve the issue.

    Any suggestions/help would be appreciated.

    I am running win xp sp2

  2. plodr

    plodr Major Geek Super Extraordinaire

    Explain what you mean by this.
    You can not mount one drive onto another.
  3. razoric

    razoric Private E-2

    I mount them into empty folders on my c (master) hard drive, using the computer/disk management utillity within administrative tools in the control panel.
  4. Broni

    Broni Private First Class

  5. razoric

    razoric Private E-2

    Am afraid that didn't work. Also if it makes any difference the drives appear to be in constant use. The working light isn't constantly on, but rather i am unable to remove them using the "safely remove hardware" function as it says "the device cannot be stopped right now, try stopping it again later"

    This makes me think the device, and thus folders are in constant use by something, and is why i'm unable to delete them???
  6. Caliban

    Caliban I don't need no steenkin' title!

    Is it possible that Windows is seeing these folders as drives or partitions? You might try booting to your Windows disk, see if they're showing as such.

    If you don't have a Windows disk, you could try booting to a live Linux environment, where you may be able to mount and manipulate the folders.
  7. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member

  8. satrow

    satrow Major Geek Extraordinaire

    A lot of this may depend on any auto-installing/-running software shipped with the external drives.

    What make/model are they?
  9. razoric

    razoric Private E-2

    pocket killbox did the trick, so many thanks for your assistance.


Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds