1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Updating Bios

Discussion in 'Software' started by ed_case7, Feb 9, 2018.

  1. ed_case7

    ed_case7 Private E-2

    Hi,

    So here's the situation: I have recently upgraded the RAM & CPU on the above machine, however even though the BIOS sees the full 4GB the OS & other utilities such as MemTest64 see the full 4Gb individually but report that only 3.12GB is usable; I know the integrated GPU will eat some of the RAM, but not nearly 900MB, this is an old machine so I'm assuming 128MB max.

    IMG_20180209_193922.jpg

    64bit.JPG

    memtest64.JPG



    I checked on the HP Support site, and there is a BIOS 1.10a that "Updates Intel Pentium 4 Processor microcode for F34, F41, F43, F49, F4A, F64, and F65 steppings."

    I downloaded the file, created a bootable USB using Rufus, MS-DOS, extracted the BIOS files using Universal Extractor and copied the extracted files onto the USB.

    At the prompt I ran ROMPAQ, which (other than giving me some warnings about not enough space to backup the files) saw and apparently updated the 1.10a BIOS; however upon restarting the machine I am still on 1.09a

    IMG_20180209_193334.jpg

    IMG_20180209_193846.jpg

    At this point I'm thinking of downgrading the BIOS to 1.08a, and then try to upgrade from there as 1.10a seems to miss 1.09a as a previous version, however any other pointers would be appreciated.

    Thanks :)
     
    AtlBo likes this.
  2. ed_case7

    ed_case7 Private E-2

    I ran out of uploads, so here goes (and my apologies for going above max pixel size on previous images, I'll take more care from now on) ;)

    BiosUpdatesB.jpg
     
  3. ed_case7

    ed_case7 Private E-2

    Ok, can't seem to downgrade either...

    1.09a is newer (release date-wise) and includes utilities for flashing. Looks like it's using .CAB files as opposed to v.1.08 & 1.10 which use .IMG files... I'm guessing HP made some other changes to the BIOS format...
     
  4. ed_case7

    ed_case7 Private E-2

    and finally, when physically upgrading from 3Gb RAM and putting the last 1GB in, the BIOS reports this (going into setup will display the full 4096MB):

    IMG_20180211_013016.jpg

    I have checked and re-checked, there is no memory mapping option in the BIOS, so I guess 3GB it is unless someone has another idea...?
     
  5. Geek_Justin

    Geek_Justin Private First Class

    A portion of your RAM goes to the video card so that might be correct for 4GB
     
  6. ed_case7

    ed_case7 Private E-2

    Hi thanks for your response, but as stated at the start there is NO WAY 800+MB is going into the graphics; it's an old INTEL 915 chipset.

    And as per my last post in the thread, it seems the BIOS is limiting the MAX RAM config, even though it sees the full 4GB in the setup; and the BIOS does not have memory mapping options.

    Regards
     
    AtlBo likes this.
  7. Eldon

    Eldon Major Geek Extraordinaire

    Reset the BIOS to Defaults as see if that helps.
     
    AtlBo likes this.
  8. ed_case7

    ed_case7 Private E-2

    Thanks for the response,

    Reset BIOS, inserted RAM and the same 3200MB configuration showed.
     
    AtlBo likes this.
  9. plodr

    plodr Major Geek Super Extraordinaire

    I was looking around to see if Pentium 4 had some sort of cap. I couldn't find anything.
    At the time 32 bit Oses were the norm. It almost seems like your computer "thinks" it has a 32 bit OS.

    My old eMachine from 2009 (32 bit Win 7 Home Prem.) with 4GB of RAM shows 2.75GB usable! Sometimes it shows more. There is no way that the integrated video is using all that RAM. Let me reboot and see how much I get.
     
    AtlBo likes this.
  10. plodr

    plodr Major Geek Super Extraordinaire

    Rebooted and it still shows only 2.75GB usable.
     
    AtlBo likes this.
  11. ed_case7

    ed_case7 Private E-2

  12. Eldon

    Eldon Major Geek Extraordinaire

    It's like Windows is ignoring 1 GB of RAM.
    My 3 GB shows 2.75 GB usable.
    RAM.jpg
     
  13. ed_case7

    ed_case7 Private E-2

    1. Run msconfig, go to Boot Tab, Advanced Options, uncheck Maximum Memory - reboot

    If you still have a problem:

    2. See if you have a memory mapping option in your BIOS, if so turn it on/off
     
  14. ed_case7

    ed_case7 Private E-2

    oh, and while you're at it check to make sure that the BIOS is seeing the 4GB; if not try removing them and replacing them one at a time as maybe you have a faulty stick...
     
  15. plodr

    plodr Major Geek Super Extraordinaire

    I'm trying to download the Crucial system scanner so it tells me what is in the computer.
    First, Palemoon has refused to completely load the Crucial site for me for a few months.
    I fired up Firefox and it seems to not want to download the scanner.

    This is going to take some time. I have Chrome portable on a USB stick - I guess I'll have to use that.

    If crucial tells me I have 3 sticks then I'll open the case up.
     
  16. plodr

    plodr Major Geek Super Extraordinaire

    Why after 5 years of having 4 GB of RAM in my system would msconfig change something ?

    Since under Windows it says i have 4GB installed, I assume the BIOS would see the same. I know sometimes the BIOS "sees" things that Windows can't but I'm unaware of the opposite - Windows seeing things that the BIOS doesn't.

    This scan is taking forever. I tried to kill it and that essentially froze up the computer. I have a shortcut to Task Manager and even that would not come up.
     
  17. plodr

    plodr Major Geek Super Extraordinaire

    Was not checked so i did not have to change a thing.
     
  18. ed_case7

    ed_case7 Private E-2

  19. the mekanic

    the mekanic Major Mekanical Geek

    The system uses RAM for other things like, graphics, your paging file and virtual memory. Try setting the virtual memory to at least 10GB.

    P.S. Or it could simply be a system board limitation.
     
    Last edited: Feb 14, 2018
    ed_case7 likes this.
  20. plodr

    plodr Major Geek Super Extraordinaire

    I ran memtest86 last night from a USB stick. No errors.
    I know my system uses some RAM for graphics. My question is What caused it to go from 3.2GB usable to 2.75GB usable? I made no changes!!! Something has to be using that memory.
    The only thing I did recently was to install 3 patches. Since it is an AMD processor, I first installed 4073578 which is a fix for AMD so 4056897 won't cause a problem. I also installed the IE Cumulative security only patch, 4056568.

    If I can't figure out what happened to the computer's missing RAM, I will restore to Feb. 6th, using an image and see if my RAM is back.
     
  21. ed_case7

    ed_case7 Private E-2

Share This Page


MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds


<