1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VIA Bus Master IDE Controller - 0571

Discussion in 'Software' started by Denise_M, Jul 19, 2008.

  1. Denise_M

    Denise_M MajorGeek


    I was going thru my list in Device Manager to see if any of my drivers needed updating. When I came to VIA Bus Master IDE Controller - 0571, I received the message in the attached screenshot.

    What is it looking for, and where can I get it?

    Attached Files:

  2. Major Attitude

    Major Attitude Co-Owner MajorGeeks.Com Staff Member

  3. Denise_M

    Denise_M MajorGeek

    I'm not too good at picking out drivers. I already have VIA, VIA823x_v140.zip -, and VIA_HyperionPro_v518a. When I was in Device Manager, about 10 devices received updated drivers. I have no idea where the updated drivers went to.

    This is what my pc has already:
    - ASUS A8V-VM SE Socket 939 Micro ATX Motherboard - UDMA133, SATA (RAID)
    . . . VIA K8M890 + VT8237A
    . . . 2000/1600 HT/s
    . . . Dual-channel DDR400, Max 2GB
    . . . VIA Integrated Gfx in North Bridge K8M890
    . . . 1 x PCI-E X16, 1 X PCI-E X 1, 2X PCI
    . . . 2 *ATA133 ,2 x SATA
    . . . 10/100 LAN
    . . . 6-Channel audio
    - Seagate Barracuda 7200.10 SATA 3.0 Gb/s 320Gb hard drive (RAID array not set up)
    - AMD Athlon Gforce 8400 64 X2 4200+ Toledo 2.2GHz 2 x 512KB L2 Cache Socket 939 Processor
    - ARCTIC COOLING Freezer 64 Pro 92mm CPU Cooler
    - Corsair 620W PSU
    - Ballistix 2x1G RAM, 184-pin DIMM, 128MX64 DDR PC3200, Unbuffered
    - BenQ DW1655 Lightscribe DVD+RW 16X8X16 DVD-RW 16X4X16 CDRW 48X48X32
    - VGA MSI NX8400GS-TD256EH 8400GS RT Video Card
    - NORCO-4618 PCI-X / PCI eSATA / SATA II / SATA I Controller Card RAID 0/1/5/10/JBOD
    - Windows XP Pro X64, SP2
    - NetFramework 2.0 Redistributable Pack for X64

    Updated Drivers:
    - Asus Bios Update v 71401
    - nVidia 175.19_geforce_winxp_whql (x64 edition display drivers)
    - Realtek ALC883 Audio Driver V5.10.0.5296
    - Realtek High Definition Audio Driver R1.96
    - SATA Controller Card 3124_x64_11130_logo
    - VIA Hyperion Pro v 518a
    . . . INF V3.00A
    . . . AGP V4.60A
    . . . V-RAID V5.70A and RAID Tools v5.40
    . . . VIA IDE Falcon Storage Device driver v2.51A
    - SiI 3124 32-bit x86 Windows BASE Driver (IDE Driver for Windows 2000, XP and 2003 Server)
    - SiI 3124 Controller Card Latest x86 BIOS V7223
    - SiI 3124 SATARAID5 Windows Driver X64 v1.5.11.0
    - SiI 3124 x64 BASE Driver
    - SiI 3124 x64 logo v1.1.13.0 for SATA Controller Card

    I've tried a lot of drivers and I have no idea the driver it needs.

    Any suggestions?
  4. Denise_M

    Denise_M MajorGeek

    I tried Driver Agent. It said that I need VIA Serial ATA Controller - 0591 Driver. The file name for this driver is VIA_HyperionPro_V509A.zip. I already have VIA_HyperionPro_v518a installed, which is a later release. Do I still need VIA_HyperionPro_V509A?
  5. musksnipe

    musksnipe Guest

    If everything is working fine and nothing is showing as missing or installed with a conflict, it's best to leave your drivers alone.
    Driver Agent is useless in my opinion.
    My drivers ARE completely up to date and it tells me I have 4 out of date. :confused
  6. Denise_M

    Denise_M MajorGeek

    I did get one error message about VIA Bus Master IDE Controller - 1501. When I went to the internet site, I have the newer release, but without it, I can't update my drivers, or that's what I think is going on.
  7. musksnipe

    musksnipe Guest

    What was the error message and where did it come from? Your system, a game, a web site, or from some app?
    If you have the newest driver and it is installed correctly (check Device Manager for drivers with problems. They will show a ? or !.) then you should be OK.
  8. Denise_M

    Denise_M MajorGeek

    I put a screenshot in the first post of the error message. I was updating my drivers when the error occurred, even though I have the newest driver installed. It may be that the older driver has a file that the newest driver doesn't have, so I installed it and I'll try to update the driver tomorrow after I reboot to see what happens.

    I don't do gaming. I watch a lot of videos on my computer. I don't go to websites except to find drivers/programs/computer help forums/and for business reasons, such as banking.
  9. musksnipe

    musksnipe Guest

    I think your PC is seeing the IDE Driver Version 570A, as 5701.
    Are you extracting the file into a folder on your PC, before trying the install?
  10. Denise_M

    Denise_M MajorGeek

    I started out by going into Device Manager and right-clicking on a device to see if Microsoft had an update for it. It updated drivers. I was surprised. This update about 10 drivers. When I got to VIA Bus Master IDE Controller - 1501, it wouldn't install because it couldn't find a missing file. I kept the newer version and added the older version of VIA Bus Master IDE Controller - 1501 to see if it would satisfy the request for VIA IDE Controller update.
  11. musksnipe

    musksnipe Guest

  12. Denise_M

    Denise_M MajorGeek

    ok, I'm a little confused here. I read the "Understanding VIA IDE driver choices"
    Version 5.70A, which was in your link, is for Vista 64-bit. I have XP Pro x64.

    What I'm confused about is its explanation:
    Because it doesn't give the version numbers, I don't know if the VIA Hyperion Pro driver that I have already includes the VIA IDE Falcon Storage Drive and the V-RAID driver. I have both VIA HyperionPro v515a and v518a. I also have VIA823x_v140 -

    According to the readme instructions that came with the HyperionPro_V515a driver, it says:

    I might be wrong, but I believe that means that the hub should work with just the HyperionPro_V515a driver. I also believe that the problem lies in the fact that I have a SiI3124 chip and the hub has a SiI3726 chip. What I'm trying to do is to install the software that the hub needs. Because I don't have a SiI3726 chip, the software doesn't install in the normal manner. I have the driver on a floppy disk because I believe it has to go thru Run, but I don't know how to do that.
  13. musksnipe

    musksnipe Guest

    This is what it says on the download page:
    Supported Operating Systems:
    Windows Vista 64-Bit, Windows Vista 32-Bit, Windows XP 64-Bit, Windows XP, Windows 98SE, Windows NT, Windows ME, Windows 2000
  14. Denise_M

    Denise_M MajorGeek

    On the top of the page, it says Windows Vista 64-Bit. I didn't go to the bottom of the page where, in the tiniest print possible, they list the other os that can use the driver.

    But that doesn't answer my question. The instructions say:

    I copied the contents of the folder onto a floppy disk. If I put the floppy in the floppy drive and start my computer, what will happen?
  15. musksnipe

    musksnipe Guest

    You asked the right amount of questions because it got me wondering. So, I did some more digging.
    I am not sure that driver I recommended is what you need.
    You do not need to put a driver on a disc for install. Discs are useful for re-installs, but not a primary one.
    Your motherboard does not show IDE drivers at ASUS.
    After more digging, I kept ending up at the Via 4 in 1 driver. The 4 in 1 contains:
    Version 5.17A of the Hyperion Pro drivers includes the following components:
    INF V3.00A
    AGP V4.60A
    V-RAID V5.70A and RAID Tools v5.40
    VIA IDE Falcon Storage Device driver v2.51A

    This should be the one you need.
    You have already updated your IDE but get the error message about the VIA Bus Master IDE Controller.
    That should be controlled by your chipset.
    The .inf contained in this download is your chipset drivers.
  16. Denise_M

    Denise_M MajorGeek

    I'm glad you thought about it because it confirmed to me that I installed the right driver (post #3 under Updated Drivers). I haven't rebooted since Saturday but I will sometime tonight. I went into Device Manager again and 2 updates were installed and I needed to reboot for them to take affect. After I reboot, I'll connect the hub again and an ext hdd and see what happens. *with a prayer to Heaven*
  17. musksnipe

    musksnipe Guest

    You should be all right.
    Usually a driver will not finish the install, if it does not find the proper hardware.

    And again, it is usually safer to set a restore point before installing drivers, so that you can reverse the install.
  18. Denise_M

    Denise_M MajorGeek

    These are the specifications on the website:

    I guess this was the hidden fact:

    OS Support

    Depends on the Upstream Host Controller. It is transparent from the Operating Systems

    I never would have guessed that it has to be transparent from my os. :ban

    In the video, it only says that "it uses a Silicon 3726 chip." To me, that doesn't mean that my pc has to have a 3726 chip but the hub has a 3726 chip. It also says that it can use any compatible port multiplier card. The fact that the hub needs a computer with a 3726 chip should have been stressed, instead of pointing out how easy it is to install.

    As I said in a previous post, if it doesn't work, I've done my best and I'll have a $139.00 paperweight.
  19. Denise_M

    Denise_M MajorGeek

    Well, I have a $139.00 paperweight. The green led on the hub doesn't light up when I connect it to a SATA II port.

    Thanks for all your help Musksnipe and Major Attitude.
  20. musksnipe

    musksnipe Guest

    :( Sorry, I couldn't help.
  21. Denise_M

    Denise_M MajorGeek

    You helped.

    I'll be starting a new thread about deleting the SiI3726 files/drivers soon.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds