1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Virtual Device Driver format in the registry is invalid

Discussion in 'Software' started by noob11, Apr 27, 2009.

  1. noob11

    noob11 Private E-2


    I am using Windows XP and currently having this error:

    SYSTEM\CurrentControlSet\Control\VirtualDeviceDrivers. VDD. Virtual Device Driver format in the registry is invalid. Choose 'Close' to terminate the application.

    I've done some research and found this site

    i tried to follow instruction
    but Im stuck at step 2 and 3.
    I cant seem to delete the default value there.

    I can make a new Multi-string Value (which is step 4)
    and rename it to VDD (Step 5)
    but that does not solve the error..

    I have also done the restoring Command.com file
    but still I cant delete the the value in VirtualDeviceDriver..
    and the error is still there..

    please help me...
  2. noob11

    noob11 Private E-2

    I realize that the link I provided was wrong..
    here is the one I am trying to follow..

    anyway, as an additional info (I dont know if it will help thou..)

    I am getting this error message three times in a row and once when I reboot (just when the desktop loads)

    So far, I've done:
    1. error-checking
    right-clicking C > properties > tools tab > error checking

    2. followed malware removal guide
    just tell me if you think you'll need the combofix.txt file to fix this problem.

    3. "16 Bit MS-DOS Subsystem" Error Message When You Install a Program
    (stuck at steps 2-3 thou..)

    and Im still getting this error..

    BTW, just tell me if this is in the wrong forum or something because I dont really know whats causing this.. (virus, malware, or software or whatever X_x)
    Last edited: Apr 28, 2009
  3. Appzalien

    Appzalien Staff Sergeant

    Whats happening to you is at some point you had a virtual drive on your pc (or might still have but its corrupted), you removed it or it broke and everytime you restart it tries to load the drivers for it but its not there. Thats why its invalid.

    If you know which virtual drive it was like Daemon Tools or Nero's Image Drive, you can reinstall it and the problem may go away once it can see it again.

    If you removed it and don't want it back its obvious that it didn't uninstall correctly. You can try to clean the registry with Tuneup Utilities trial or run a driver cleaner to see if it can find the Virtual device drivers but use it only if it says specifically it found drivers for the same virtual drive you removed.

    On my system I have Daemon Tools installed and if I go into Device Manager and open the DVD/CD-Rom Drives listing, the virtual drive is listed as an scsi drive with no brand name for it. You can uninstall it from here but if its still there even after you have uninstalled it from add/remove programs then something went wrong.
  4. noob11

    noob11 Private E-2

    ok now I think its fixed..

    this is what Ive done (I dont know how I fixed it though its one of these)

    1. Ive uninstall all of my anti-viruses except AVG
    2. install again Spyware terminator to protect my computer.
    3. done a scan. fixed some problem
    4. reboot

    and then the error was just gone!

    thank you very much for replying.
    I appreciate it.
    Ill come back here when I got a new virus!
    Im so happy :-D
  5. Appzalien

    Appzalien Staff Sergeant

    Its a good idea to have only one anti-virus active at a time. You can have a whole bunch of spyware apps but only one anti-virus and one firewall at a time. they conflict with one another and cause problems.
  6. Jeack

    Jeack Private E-2

    Had this error start to crop up run running the 16-bit "Superbase" Program. I'm currently using Windows 7 32-bit.

    Found some excellent advice at this site:


    Being a noob as far as registry editing, my Windows 7 editor is "regedit.exe".

    Fumbled a bit, but as soon as I made the changes to the Registry, Superbase loaded and ran just fine.

    I did "export" the Registry before making the changes though!

    I'm attaching a screenshot. Good luck!


    Attached Files:

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds