1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows Update Issues

Discussion in 'Software' started by LoLyfe, Mar 12, 2014.

  1. LoLyfe

    LoLyfe Private E-2

    I've been having a problem for a while now and have only just gotten around to having a look into it. But I seem to have exhausted everything suggested on the Microsoft support sites and thought I'd turn to the experts...

    Since December, I have been unable to install the Windows Malicious Software Removal Tool and subsequently, updates for the .NET Framework will not install either. Today, the Security update for Silverlight won't install either.
    All other Windows Updates seem to download and install without a problem via the Windows Update facility.


    The system itself seems to be okay apart from the update problem which is now 5 items:

    Security Update for Microsoft Silverlight (KB293677)
    Microsoft .NET Framework 4.5.1 for Windows 7 x64 (KB2858725)
    Security Update for Microsoft .NET Framework 4 (KB2898855)
    Security Update for Microsoft .NET Framework 4 (KB2901110)
    Windows Malicious Software Removal Tool x64 - March 2014 (KB890830)

    I have had a couple of failure codes, unfortunately I didn't make a note of them. Today's failure code is: Code 656, which I believe only relates to Silverlight.

    I really don't want to have to reinstall Windows unless it's completely necessary so I was hoping someone here might have a suggestion...

    Many thanks in advance
    Lo

    SYSTEM DETAILS
    =============

    SONY VAIO VPCEB2C5E
    Intel Core i5 M520 2.40GHz
    4GB RAM
    Windows 7 Home Premium SP1
     
  2. Spad

    Spad MajorGeek

    Have you visited the Microsoft Fix It pages on their website? It has several automated tools you can run to fix various windows problems, and specifically issues with Windows Update.

    Worth a try. I've had it correct some odd things 7 has done on my computers.
     
  3. LoLyfe

    LoLyfe Private E-2

    Hi,
    Yes, I've tried that route. The Fix It app suggested problems with the .NET Framework install, fixed it but the same issues persisted.
     
  4. rjordan

    rjordan Private First Class

    Check the following services and make sure they can be started -
    BITS (Background Intelligent Transfer Service)
    BFE (Base Filtering Engine)
    Security Center
    Windows Firewall
    Windows Update

    Try to do the updates 1 at a time to try and narrow down if it is an issue with a specific update.

    Reboot PC, stop Windows Update Service. Navigate to C:\Windows\SoftwareDistibution and rename it to SoftwareDistribution.old. Start Windows Update Service. Try running updates again.

    If all those steps turn out fine, you could try running Tweaking
     
  5. plodr

    plodr Major Geek Super Extraordinaire

    Since KB2858725 is from November 2013, try the offline installer
    http://www.microsoft.com/en-us/download/details.aspx?id=40779

    Only do this, no other and then reboot. Does it install? If so look at the updates again and the three .NET framework updates should now disappear. (If you update to .Net 4.5.1, then .NET 4 is replaced and does not need updating).
     
  6. LoLyfe

    LoLyfe Private E-2

    Thanks for the response.

    Done. No problems with these at all.

    All 5 existing updates fail except Mailicious Software Removal Tool - This successfully installed - however, when checking for updates again, it reappears as if it has never been installed. The update history shows it to have been installed okay.

    Done this too - same problems persist.

    Nice little application this one, it ran smoothly will no errors reported. Tried the updates again, still no good.
     
  7. LoLyfe

    LoLyfe Private E-2

    This failed too. Downloaded, extracted and verified but fails to install. There is a dialog that opens stating that I can look at a log file but the link doesn't work. It also says that an option will appear to send a report to Microsoft - this doesn't appear either...
     
  8. LoLyfe

    LoLyfe Private E-2

    After further research, I found other users with similar issues. Their way to resolve this was to uninstall all instances of the .NET Framework and start from scratch.
    Using IObit, I have attempted to remove all mentions of the .NET Framework but haven't ventured any further than this (no manual removal of any files).
    I then retried an offline install of .NET Framework 4.5.1 and it failed once more. The exact response I get from this is:

    Again, the option to look at a log file exists but it fails to open if I try to take a look. I've manually searched for the log file but not really sure what I'm looking for. I did find the Windows\Microsoft.NET folder but there are no logs pertaining to the attempted install.

    If I now look at my list of installed programs, the .NET Framework doesn't appear at all.

    This error leads me to think that there's a problem with the Windows Installer but I'm confused. I am able to use the Windows update to install updates to Security Essentials, and all other updates that are listed seem to install without a problem. But those original 5 updates just won't play the game...

    I think I'm getting close to throwing in the towel and restoring the VAIO to it's factory condition but I'd really like to know what's going on...
     
  9. LoLyfe

    LoLyfe Private E-2

    More info:

    Upon investigating the error with the Windows Installer, I came across this on the Microsoft Support forums, which took me through some steps to repair the registry settings, start the program manually and uninstall earlier versions.

    The first two steps proved to be hapless, the third took me to an MSDN site that offered a .NET cleanup tool which removes everything .NET related so that a fresh install can be performed.

    I ran this and even though I didn't seem to have any .NET Framework installed, it did find v2 and removed it.

    When running the Windows Update now, I get the following:

    3 important updates:
    Security Update for Microsoft Silverlight (KB293677)
    Microsoft .NET Framework 4.5.1 for Windows 7 x64 (KB2858725)
    Windows Malicious Software Removal Tool x64 - March 2014 (KB890830)

    I attempted to install these one-at-a-time, but still no luck. Except for the Malicious Software Removal Tool, which stated it was installed successfully - however when I refresh the updates it appears again.

    Followed up with offline attempts too - no luck there either.

    Today's definition update for Microsoft Security Essentials installed without a hitch.
     
  10. plodr

    plodr Major Geek Super Extraordinaire

    To sort through any .NET issues, I rely on Aaron Stebner and his tools.

    First run this: http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx
    and see what versions of .NET it finds.
    Manual method: go into the registry and HKLM\Software\Microsoft\Net Framework Setup\NDP

    See if fixing Windows Installer works.
    http://support.microsoft.com/kb/2642495
    will show folders for 2, 3, 3.5, 4 and 4.0
    There is no folder for 4.5. To see if 4.5 is installed, you open v4 and click on Full. In the right pane there is an entry Version (not Target Version) and 4.5 is there.

    Fix Windows Update?
    http://support.microsoft.com/kb/971058/en-us
     
  11. LoLyfe

    LoLyfe Private E-2

    Thanks again for the reply.

    I've used Aaron Stebner's MSDN site previously but thought I'd run through it again.

    The Verification Tool suggested that I had versions 2 and 3 still installed, even though a previous check using another too said I did not. Because of this, I used Aaron's .NET Framework Repair Tool - however, this has proved to be a problem. I left it running overnight, and this morning it's still at the Collecting Logs stage.
    I don't want to quit out of it but I'm at a loss as to what to do really because it's been stuck in the same state for about 10 hours now.
     
  12. plodr

    plodr Major Geek Super Extraordinaire

    I'd probably end up shutting it down after 10 hours.

    Look in your registry at the path I showed you and see if you have anything inside the v2 and v3 folders.
     
  13. plodr

    plodr Major Geek Super Extraordinaire

    I ran the tool on my Win 7 64 bit Home premium and I have
    2.0 SP2, 3.0 SP2, 3.5 SP1, 4 Client, 4 Full and 4.5

    Win 7 comes with 3.5 installed and I did not install the lower versions so they must have been on the netbook.

    The older Win 7 64 bit Home Premium netbook has 2.0 SP2, 3.0SP2, and 3.5SP1.

    I have no trouble updating on either. .NET 4 and 4.5 clearly, if not installed are not needed to get update working.

    Do you remember if you installed .NET 4 as an update? If you did, we can concentrate only getting v2, v3, and v3.5 on and working.

    Also, I have Silverlight on both netbooks and installed the March update on both.
     
  14. plodr

    plodr Major Geek Super Extraordinaire

  15. LoLyfe

    LoLyfe Private E-2

    Ran the verification tool, I've got:

    .NET Framework 2.0 SP2
    .NET Framework 3.0 SP2
    .NET Framework 3.5 SP1

    In regedit I was able to locate folders:

    v2.0.50727
    v3.0

    Then tried to fix the Windows Installer using methods as suggested, the only thing that didn't square up was that my status was 'Started' and not 'Running'. Attempted an offline install - no good.

    Re-ran the Fixit tool and tried a Windows Update when asked, which I did and got a brand new error code:

    "WindowsUpdate_000013EC" "WindowsUpdate_dt000".

    Put this new error through a search at Microsoft and got a link for the Windows Update troubleshooter. On completion of running this I ended up with a log that listed the following issues:

    Windows Update error 0x80070057 (2014-03-15-T-10_04_07A)......Not fixed
    Problems installing recent updates.............................................Not fixed
    Problems installing recent updates.............................................Not fixed
    Check for missing or corrupt files...............................................Detected
    Some security settings are missing or have been changed..............Fixed
    Service registration is missing or corrupt.....................................Fixed

    There is a full report that I was able to print to a .xps document and have zipped as an attachment, but I doubt whether it will give any pertinent information. However, it's there if you're interested.

    At the end of the troubleshooter, there is an option to either Explore additional options or close. Clicking on Explore gave me the standard windows troubleshooter/help dialog.
    On the off chance that the above two fixes helped, I ran an offline install but
    had no success.

    Another trawl through the Microsoft help areas gave me a page for a hotfix for Windows Update. This, of course, didn't install and I was given the very helpful error report:
    I'm having to walk away to give my brain a rest, I'm losing track of what I've done and where I'm at. Will come back to it in a bit...
     

    Attached Files:

  16. _nullptr

    _nullptr Major Geeky Geek Geek

  17. LoLyfe

    LoLyfe Private E-2

    Yes, tried the scan - no integrity violations found.

    The System Update Readiness Tool was the Hotfix for Windows (KB947821) I mentioned above.
     
  18. LoLyfe

    LoLyfe Private E-2

    Due to the fact that the .NET Framework version 4 is required for an app that I use pretty much all the time, and that the last backup of this app I did was midway through February, I panicked a t bit... to that end, I went to system restore and have now fallen back any and all changes to when I installed IOBit Uninstaller.
    Once I did that, I used the verification tool to see how I stood, which is:

    .NET Framework 2.0 SP2
    .NET Framework 3.0 SP2
    .NET Framework 3.5 SP1
    .NET Framework 4 Client
    .NET Framework 4 Full

    This has enabled me to run the app I needed and do a full backup.

    This now means (I assume) that any and all work I've done since installing IOBit on the 13th is now redundant.

    So to re-clarify, if I now run Windows Update I'm back to the original 5 issues:

    Security Update for Microsoft Silverlight (KB293677)
    Microsoft .NET Framework 4.5.1 for Windows 7 x64 (KB2858725)
    Security Update for Microsoft .NET Framework 4 (KB2898855)
    Security Update for Microsoft .NET Framework 4 (KB2901110)
    Windows Malicious Software Removal Tool x64 - March 2014 (KB890830)

    I tried to run these updates individually but the same problem persists.


    Error responses:

    Security Update for Microsoft Silverlight - Error 656

    Microsoft .NET Framework 4.5.1 - Error 641

    Security Update for Microsoft .NET Framework 4 (KB2898855) - Error 641

    Security Update for Microsoft .NET Framework 4 (KB2901110) - Error 641

    Windows Malicious Software Removal Tool - stated it was successfully updated. However, on a refresh of the Windows Update, the update was back in the list.
     
  19. plodr

    plodr Major Geek Super Extraordinaire

    You can hide .NET 4.5.1 You don't need it for a Win 7 computer to work. One of our netbooks and my husband's desktop Win 7 Pro 32 bit don't have it installed.

    I'll have to do some more searching to see what to do about the errors with the 3 remaining updates and the removal tool repeatedly offered. (I had the tool repeatedly offered to me late 2013 but it was a problem on MS's part). I have to see if anyone had the problem this month.
     
  20. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member

    Hi

    for some of the errors you are getting, they could link to using multiple security software's so what security (antivirus, antimalware etc) software do you have installed, and if you disable or uninstall them, then can you update ok?

    Can also try resetting Windows Update HERE
     
  21. LoLyfe

    LoLyfe Private E-2

    Thanks again for spending the time to look into this, I really appreciate it.

    I've hidden the 4.5.1 update on this (VAIO) laptop.

    I checked my desktop PC and it's running 4.5.1 without any hitch that I've noticed, so it's only my laptop that's affected.
     
  22. LoLyfe

    LoLyfe Private E-2

    I'm running Microsoft Security Essentials and the Windows Firewall - no other security installed at the moment.

    I've tried resetting the Windows Update, yes - no luck.

    Thanks for the reply...
     
  23. camfers

    camfers Private E-2

    Hi Guys,

    I've been searching on the same issue and found this Forum entry. I have EXACTLY the same update issues as Lolyfe, and started down the same route. The Repair Tool hangs at "Collecting Logs".... if I had taken all the trouble he/she has, I'd have had a breakdown by now.:cry

    Mine is also a Vaio - VPCEB4B4E (bought in Italy), similar spec.

    So, whilst I still don't know exactly what they are or why I need them, I will hide the offending updates and keep my fingers crossed that Microsoft - or Sony - eventually find out about the issue(s) and fix it/them.

    But thanks to Lolyfe and all of you who have tried to fix the problem.
     
  24. RangerGord

    RangerGord Guest

    Had the same problem. After many failed attempts at correcting it I simply left it alone and a week later it installed fine.
     

Share This Page


MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds


<