1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows won't install network controller driver

Discussion in 'Software' started by somewhat, May 5, 2011.

  1. somewhat

    somewhat Private E-2

    I made an account and a thread the other day, but somehow both have completely mysteriously disappeared. The only proof I was ever here is the confirmation email I received.

    Anywho, havin' a bit of a problem here.

    I've had a Thinkpad T40 for a few years now, and I've finally tried to fix an old reoccurring problem. Apparently when the computer, after a few weeks or months of working, decides to check the mini pci network adapter against a whitelist and decides that it's unauthorized to run. So I removed the mini pci card, ran a code or program (whatever it's called) on a bootable disk. The program was called no-1802 (1802 is the error I'd get when it wouldn't let me boot with the card). Then plugged the card back in and booted. The 1802 error went away, and Windows recognized the network controller as new hardware, but asked for drivers. When I tell it exactly where the driver is, it can't find it. I have no idea what's wrong, as I give it the straight address of the driver, and it just doesn't see it. This is driving me nuts, and any and all help is appreciated.



    (And if anyone has any idea what happened to my original account under the name Glutton, I'm a bit curious about that as well.)
  2. falconattack

    falconattack Command Sergeant Major

    What is youur operation system ? Take a look here !! :cool




  3. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member


    On your account I have no idea off hand, have checked and can see nothing wrong in the logs.

    What is your Windows version and Service Pack?
    In Device Manager do you have any yellow ! marks and if so by what devices?

    what is the model and version code of the mini card?

    Could you link us to the location you downloaded the drivers from (I just want to see the files) and was their an setup.exe or .exe file to run to install the drivers or are these just a collection of .ini and .dat files etc
  4. somewhat

    somewhat Private E-2

  5. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member


    Their are a few different model T40's IBMs so could you run the below as written and attach the log, or if underneath the laptop it has a code like T40-2374 or alike, then post that.

    Also yes the Cisco network card should have version model codes on it.

    Asking for the exact model due to various ones having different hardware and with the exact model variant we should be able to clear up all those other drivers.

    When installing the Cisco Netword card did you follow this advice below, I've cut at pasted it from the install instructions from the page you listed for the driver.

    Clean install: (Found New Hardware Wizard)
    If this is the first time booting Windows XP after installing the
    Cisco Wireless LAN Mini-PCI Card in the computer, Windows XP will
    detect the card automatically. To install the device driver, follow
    the instructions below.

  6. somewhat

    somewhat Private E-2

    The card is a cisco aironet MPI350.

    Laptop is a T40 type 2373

    The driver has worked before, perfectly. Never had a problem installing it until I ran this no-1802 thing. Usually after a fresh OS install the card would work fine for a few months, then God knows what would happen and I'd get the 1802 error. So I'm sure the driver is the correct one. The computer just won't install it.
  7. falconattack

    falconattack Command Sergeant Major

    Is this your error message ( 1802: Unauthorized network card is plugged in
    Power off and remove the miniPCI network card ) ? :cool
  8. somewhat

    somewhat Private E-2

    No, it started as that. I removed the minipci card and ran a no-1802 fix program. Then plugged it back in and now I can't install the driver for it.
  9. somewhat

    somewhat Private E-2


    Haha, it fixed itself. I just powered the computer on, the driver is installed and it's working. I wish I knew what happened. Thanks for all the help guys, I appreciate it.

    I think after several years I finally booted the 1802 problem on this thing. SAICK!
  10. somewhat

    somewhat Private E-2

    DAMNIT! Nevermind, still screwed. I don't know why it worked a minute ago, but after a reboot I'm at the same problem. Won't see the driver.
  11. somewhat

    somewhat Private E-2

    Any ideas at all? I'm stumped.
  12. somewhat

    somewhat Private E-2

    Guess I'll try reinstalling windows and post the results.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds